function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Rajesh NkRajesh Nk 

lightning container - static resource throws "403 Forbidden" error in container.js - test html iframe works!

Issue: Lightning Container loading a jquery fileupload widget as a static resource - throws "403 Forbidden" error in container.js

Plain iframe works
    <iframe src="/resource/jqfileupload/fileupload/index.html"></iframe>
Same static resource fails in lightning container with 403    
    <lightning:container src="{!$Resource.jqfileupload + '/fileupload/index.html'}"/>

Any help is greatly appreciated. Thanks!

Rajesh NkRajesh Nk
Missed adding the failing url - 
This is the Ligntning container failing url - 403 forbidden
I have the same issue, waiting on feedback from product management. I also noticed that if you replace the "lcc/1518827337000" with "resource" in the rendered page it works.
Ron Mccrerey 20Ron Mccrerey 20
Try unchecking "the Lock sessions to the domain in which they were first used" in session setting has resolved your issue.
Also if using sandbox it appears that the sandbox name must be in lower case.
Andrej Mihachou 17Andrej Mihachou 17
@Ron Mccrerey 20, tried your suggestion. Unfourtunately, the issue persists. Any other ideas?

Had the same issue.  by default lightning:container looks for index.html and should be present on the first level of your directory structure.  If you want to customize please include a manifest.json file.

I am facing the same issue, @Rajesh Nk were you able to resolve the issue?
Ravi Patel 103Ravi Patel 103
This is defenately issue from salesforce, @salesforce-team you guys need to figure this out.
I was getting same 403 issue while I was using chrome.
But I tried on another browser, it was working fine, I think its caching issue from sales forces, it keeps expired token or something.
Mark Purick 9Mark Purick 9
I had this issue. My index.html was in the dist folder and not the first level of the directory structure of my zip file. I zipped the files inside the dist and it worked fine.
Alberto MataAlberto Mata
It seems LCC does not recognize index.html unless it is at top level folder. I am trying to integrate ReactJS with Aura and putting index.html at the root folder of my zip was the solution.