function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Kevin Chew 5Kevin Chew 5 

Getting this error: Challenge Not yet complete... here's what's wrong: Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'

Challenge Requirements:
Create a flow:
Name: New Lead
Type: Screen Flow
In the flow, add a screen with these required screen fields.
Last Name
Company Name
In the flow, create a lead record.
Use the screen fields to set the lead’s Last Name and Company.
Store the lead’s ID in a Text variable called leadId.
In the flow, add another screen with a Lightning component screen field.
Name the field Upload_File
Choose the forceContent:fileUpload Lightning component.
Use the leadId variable to set the component's Related Record ID attribute.
Activate the New Lead flow.
Create a new Lightning page:
Type: Home page
Label: Process Automation Home
In Process Automation Home, add a Flow component that references the New Lead flow.
Activate the page and set it as the default Home page.

I did all of this and yet it says it cannot detect force content?User-added image
User-added image
Inna GuptaInna Gupta
I am also getting the same error. Please let me know if you are able to resolve the issue.
LaTashia SmithLaTashia Smith
Same!! Making me go crazy!
Terry HaleTerry Hale
I am also getting the exact same.  Any help would be appreciated.
Lawson Kita 33Lawson Kita 33
I was having the same trouble as well.  I started a brand new playground just make sure that wasn't causing the issue.  Then I followed the steps under the secction "Create the Second Screen"  in the lesson.  Not sure if following step 2 "Under Navigation Actions, deselect Allow Previous.
Otherwise, if users navigate back to the first screen, multiple accounts will be accidentally created" or sub step 3 "Click Add Row and select Allow Multiple Files. For the value, type true and select$GlobalConstant.True."  made it possible to complete the challeng.  In any case following the steps in "Create the Second Screen" using Upload_File for the unique name.

Also try setting the "Enable Lightning runtime for flows" in  Process Automation Settings to true.
Igor Massayuki SerikavaIgor Massayuki Serikava
Getting the same error. I've created another Playground but it didn't work.
Kevin Chew 5Kevin Chew 5
I tried creating another playground and everthing was exactly as it should be. Yet the error message persists. Can we reach out to anyone who oversees these?
Thomas GirardeyThomas Girardey
Same issue here
Same here! I am so annoyed. Spent like 3 hours on this today. There has got to be some kind of bug. Where's the vodka? 
One question..are you guys using the "General Info" tab as the unique name, or under "Field Settings?" I find that if i tried to name them both the same that I get an error stating that it isn't a unique name. 
Lawson Kita 33Lawson Kita 33
First sorry for leading you down the wrong path with my last comment.
I agree with Brian Parker.  Think there is some kind of bug.  Once I created a flow where the unique name for the ligthning component field was wrong, but the label was Upload_File.  The challenge passed.  Using the same trailhead workspace I tried to make it fail by making everything wrong and it still passed.

I then spun up a 2nd brand new trailhead workspace and set the unique name to Upload_File and it passed. 

I remember this happening with the process superbadge.  Had to really finagle it to get it to pass.
Christopher Farid BaloloyChristopher Farid Baloloy
Tried everything suggested but keeps failing! Argh! #Bug
Ewout FransEwout Frans
Same for me, but I first had File_upload without the U as a capital. After changing it, I still have the issue. So probably indeed a bug? Does someone from Salesforce interact on this forum or not? I will try to report it as a bug...
Having same Issue, Please let us know if anyone contacted support, Unable to complete the Module.
1. Tried Changing variable types for leadId.
2. Enable Lightning runtime for flows is checked.
Getting below Error on homepage too.
"We can't launch this flow because of a variable error. Send this error message to your admin. The value null is being provided for variable leadId but isn't compatible with the variable's data type (String). Check the places where you implemented the flow ‒ such as through a Lightning page or a custom button ‒ and make sure that all provided values are compatible with the variables' data types."
Gajendra TyagiGajendra Tyagi
Same for me. Tried different different scenarios, but not able to complete. 
Imran SarwarImran Sarwar
1- Delete last screen which has "Upload File" and save as new version.
2- Open new version and create new screen and add upload file field and save as a new version
3- Activative this latest version.

This should fix your issues. 
Chris DuarteChris Duarte
I am sorry about this. We discovered that the challenge checker is looking for the second screen name to be Upload_Files (with an s on the end) rather than the lightning component being called Upload_File. We're getting it fixed. In the meantime, if you change the second screen name unique name to Upload_Files, you should be able to get through it.

We made a knowledge article on this (see below). My apologies again.
Manish Rai 22Manish Rai 22
Thanks Chris!!
The knowledge article you have shared is working and I am to complete my challenge. However, it took more than two days to figure out that I am doing everything correctly and there is something not correct at Salesforce trailhead end. Please get this fixed on priority as it would be killing lot of time for many trailhead users.
Chris DuarteChris Duarte
@Manish yes, we will get it fixed. My apologies again.
Lawson Kita 33Lawson Kita 33
@Chris, THanks for your help in resolving this. 

Your instructions says "change the second screen name unique name to Upload_Files".  If this is the case then the instructions on the trailhead challenge should be updated as well.  The instructions are "Name the field Upload_File".  This now explains when I was able to get the challenge to pass twice despite having the unique name for the field wrong.  I had partially followed the stepts in the "Create The Second Screen" section and added and underscore for the screen name. 

If this is not going to be an immediate fix, maybe modifiying the challenge instructions would at least be a quick temporary fix that would help out a lot of people.

Also how do we contact support for future issues with trailhead? I was looking around and couldn't find it.

Thanks again
Tom Mendoza 12Tom Mendoza 12
I'm having the same issue with: Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'. 
Gajendra TyagiGajendra Tyagi
@Chris, Thanks for your help. It worked after chaning the unique name to Upload_Files.
LaTashia SmithLaTashia Smith
This suggestion still doesn't work for me. Getting the same error message after changing unique name to Upload_Files. 
Chris DuarteChris Duarte
@Lawson yes, I mentioned this in my post. We're aware the instructions don't match what is being checked. I made the knowledge article to broadly communicate the workaround until I can get it fixed in Trailhead. It will be fixed in our next content release.
Kevin Gallimore 10Kevin Gallimore 10
@Chris Thank you. I've tried to troubleshoot this on my own for hours now, making over 20 versions before I sought out help. I wanted to make sure I was able to find the issue on my own to learn from my mistake. I realized there must be a bug. Thank you for posting this.
Chris DuarteChris Duarte
@Kevin I'm so sorry you spent so much time. 
LaTashia SmithLaTashia Smith
@Chris - what happens if what you suggested still is not working? 
Chris DuarteChris Duarte
@LaTashia you likely have something configured incorrectly in your flow. You should go back over all the steps and make sure you did everything correctly. You can always use the feedback link in Trailhead to reach out to Trailhead Support. It's on the right side of every page.
Ghazaleh NazariGhazaleh Nazari
Please help:
Challenge Not yet complete... here's what's wrong: 
Can't find the 'New Lead' flow in the 'Process Automation Home' page. Make sure the Developer Name of the page is 'Process_Automation_Home'.  This is the error I get. But the name is correct and when I try to delete the Process Automation Home it does not allow me. Not sure what to do
Never noticed a feedback link, that’s good to know!
This entire section on trailhead seems to be a little sloppy. I’ve noticed several inconsistencies with directions and names, etc. thankfully I’ve got this one behind me but not after spending at least triple the amount of time. 
Chris DuarteChris Duarte
I went through the entire module "Lightning Flow" in detail after this happened. I didn't see any other places where instructions were incorrect (other than this bad challenge). What did I miss @Brian?
Mohammad AnisMohammad Anis
To cut short, the Screen unique name should be : "Upload_Files" & Lightning component field unique name shoud be : "Upload_File" .
Vipul Kumar 12Vipul Kumar 12
Thanks @@Mohammad anis,your solution worked...
such an silly mistakes ,i think this confusion should be fixed in trailhead.
Vipul Kumar 12Vipul Kumar 12
@@chris durate follow this one... the Screen unique name should be : "Upload_Files" & Lightning component field unique name shoud be : "Upload_File" .

's' is the difference between many ''version of frustration'' and 500 shiny point.
Chris DuarteChris Duarte
@Vipul I'm not sure why you're writing that to me. If you scroll up, you'll see I'm the person who created the knowledge article and informed you of the workaround. And we will get it fixed in our next release. I'm giving you the workaround so that you can pass now.

@Mohammed we are not checking for the name of the Lightning Component. We are checking for the second screen name only.
Ghazaleh NazariGhazaleh Nazari
@Chris Duarte still waiting for my response. This is frustrating,.
Chris DuarteChris Duarte
@Ghazaleh use the feedback link in Trailhead to request help. Your issue is unrelated to the one in this thread.
Vipul Kumar 12Vipul Kumar 12
@chris yes... thankyou for ur all effort ....
oh my finally!! was starting to lose my mind, was on it for like 30 min going through the instructions over and over again!
Thank you @Chris Duarte
Chris DuarteChris Duarte
Thanks for hanging in there, @Fabi! My apologies for the experience. We'll get it fixed soon.
Thanks @Chris wa facing the same issue. Now with the knwledge article you share It worked. But, yup it took time to realise that there is some issue in the Challege Checker.
Adam DillmanAdam Dillman
All this time I thought the lightning component needed to be named "Upload_File", not the screen. ¯\_(ツ)_/¯ 
Chris DuarteChris Duarte
@Adam yes, that's what it's supposed to be, but not what it's currently doing. We're getting it fixed, but in the meantime, this is the workaround.
Hristo BanovHristo Banov
@chris - this worked. I guess the people who are still getting an error are changing the Lightening Component Name and not the screen name. It's frustrating, but, eh, mistakes happen. 
Chris DuarteChris Duarte
@Hristo Agree. We will get it fixed shortly. My apologies for the frustration you encountered.
Kristopher EagerKristopher Eager
@Chris Thank you so much!
Renu Adhikari 7Renu Adhikari 7
Yes, trailhead is not checking for the name of the Lightning Component. They are only verifying the second screen name only. So, first screens - Upload_Files and field of Lightning Component can be anything like Files. Thanks @Chris. It took my 2 days to complete this :( 
Angi SivakumarAngi Sivakumar
@Chris & others, thanks for the solution. That was frustrating but I can move on now:)
Raj KarraRaj Karra
Finaly after trying for more than two hours got this working, was getting few validation messages for the unique name and managed to save the fow and it worked fine. Though it was frustrating, had a good pratice of creating flows.
@Chris, appreciate your patience in replying to the community.
Chris DuarteChris Duarte
I'm very sorry about the error @Raj -- we have the fix ready for release early next week.
Akaash KBAkaash KB
@Ghazaleh I too got same error as you. Go to your Lightning app builder and select your Home page of this exercise and modify the developer name field to Process_Automation_Home

User-added image
Adam KundratAdam Kundrat
I'm glad you guys have a fix and workaround but I think it would be great to note it on the exercise. I just wasted so much time trying to resolve this.
Chris DuarteChris Duarte
@Adam: We cannot note it on the exercise without a release to production. If we're going to do a release to production, then we should simply fix the challenge; and we're doing that this week.
Tony NelsonTony Nelson
Spent a good 15 minutes trying to figure out what I might have done wrong in this exercise. Since I wasn't able to find anything inconsistent with the instructions, I headed to the forums and found this thread and the answer in under 5 minutes. Simple solution, thank you @Chris Duarte.  Everyone who is giving you a hard time about this clearly has not created public training materials. Small mistakes like this happen all the time, which isn't a big deal as long as they get fixed. Thankfully, @Chris has been very responsive and it sounds like this will get resolved for future Trailhead goers later this week.
Chris DuarteChris Duarte
Issue now resolved in production. We are now checking for what is documented in the challenge. You can disregard the workaround.

My apologies again for the trouble.
Kumar Vikash 9Kumar Vikash 9

Damn.. I had been renaming the screen name all this time. Almost left this challenge!!

Thanks Chris for fixing the issue as well as the documentation!

Chris DuarteChris Duarte
Yes, even though we resolved the underlying issue, I still think the UX is a bit confusing here. When you add the component, you have to click Field Settings tab to change the name of the field. I think we can clarify this further in the challenge requirements.
geoffrey bauergeoffrey bauer
Couldn't  agree more Chris, same goes for the 'Formulas and Validations/Use Formula Fields' challenge which I spent 20 hours on before giving up. I am about 4 hours deep into this challenge with no resolution and only doing these Trailheads because of the financial rewards offered to Veterans. Otherwise, I would have sat for the cert exam 2 weeks ago. 
There is certainly no learning going on with buggy/poorly constructed Trailheads. I would recommend newbies to take the classes at Udemy given by SF pros for $10. The cost is much, much more severe on these Trailheads!
Chris DuarteChris Duarte
@Geoffrey are you having an issue with the Lightning Flow challenge, or a different challenge? If it's a different challenge, what specifically are you stuck on? What errors are you getting? 
geoffrey bauergeoffrey bauer
Hi Chris, Currently stuck on 2 challenges. I was able to get through the flow challenge issue after fix. (5 hours) 1.'AppEchangeBasics/Install APPExchange packages'-challenge asks for a simple download of the 'Salesforce Adoption Dashboards' When I go to download the app ( In my new DE instance) I get 'URL NO LONGER EXISTS' When I try to complete challenge using other accounts where I have this app installed I get... Our trailbots are having a problem accessing your hands-on org. Please try again and if this issue persists refer to this article to fix the problem. 2. I set up a new DE sandbox to wrestle with another challenge. I did this under a different email, Anyway, I can't link my accounts together to aggregate my badges in Trailhead. System is saying other account used by someone else. 3. The reason I set up another account was for the challenge in, 'Formulas and Validations/Use Formula Fields' *my *persistent error message is * The 'Days_Remaining__c' formula field did not return the correct number of days between the contract end date and today.'AND it doesn't. When I looked at the date fields the formula refers to ( Today() - account.LastActivityDate ),the result is 354 or 558 days and it should yield 0 days.I have tried other networks, browsers and accounts with every solution offered over the past 3 years.(WHY is this challenge still being offered?)Anyway, until I get these issues solved, I am stopped from receiving Veteran's assistance. Which is very generous by SF.Thanks,Geoff*
Chris DuarteChris Duarte
@Geoffrey I am sorry to hear you've had trouble with these challenges. Both the Adoption Dashboards and Formula Fields challenges are working as expected -- that's why the challenges are live on the site. I recommend you click the feedback link in Trailhead to get help from our support team, if what I post below doesn't solve your issue.

1. Reports & Dashboards
  • Get your username and password for your Trailhead Playground using the instructions in this article (
  • Install Salesforce Adoption Dashboards ( from AppExchange into your Trailhead Playground
  • Refresh the 3 - Sales & Marketing Adoption dashboard in the Salesforce Adoption Dashboards folder at least once 
  • In the 3 - Sales & Marketing Adoption dashboard, edit the New LEAD Trend by Source component and uncheck the Use chart as defined in source report option
  • Change the dashboard component for New LEAD Trend by Source to a pie chart and set the wedges to Lead Source
  • Save your changes
For this, the easiest thing to do is open the Trailhead Playground, and delete everything in the URL after Then paste this at the end: packagingSetupUI/

So let's say your Trailhead Playground URL is this:
Delete this part: one/
Leaving this part:
And now paste on this part: packagingSetupUI/

That will force the app to install in the correct place.

2. Account merges:

3. Formulas & Validations

Create a formula field that determines the number of days between the end date of a contract and today.
Your renewals team wants to see how many days are left before a contract expires. Create a formula field that meets these requirements.
  • Object: Contract
  • Formula Return Type: Number
  • Field Label: Days Remaining
  • Field Name: Days_Remaining
  • Field Level Security: Visible and Read-Only for all profiles
  • Add the field to the standard Contract Layout page layout
  • The formula should return the number of days between the contract end date and today
  • The resulting API name for the field should be Days_Remaining__c
In this case, you want to create the field on the Contracts object (not Contacts -- note the "r" in the name of the object). You want it to be a Number type field and you want it to create a formula where you subtract TODAY() from the Contract End Date (which is a standard field on the Contracts object).
Kevin DombroskiKevin Dombroski
@Chris - I have been wrestling with the "Can't find the 'New Lead' flow in the 'Process Automation Home' page. Make sure the Developer Name of the page is 'Process_Automation_Home'."  I have checked the Developer Page Name, and it is indeed "Process_Automation_Home", as well as my flow is named "New Lead". Any suggestions?  Please let me know! 

Here are some visuals: 

Properly named screen

Configured Home Page containing my flow

Working Home page / Flow in Action

Chris DuarteChris Duarte
@Kevin It looks like you have your pages named right. Do you have any duplicates in your org? More than one Process Automation Home page? More than one flow named New Lead? I also notice you've got the Dreamhouse app installed there; could you try uninstalling that?
Kevin DombroskiKevin Dombroski
Thanks @Chris - after I triple-checked everything, I noticed that although my flow's name was "New Lead", it retained an incorrect value for the "Unique Name" (it was Quick_Lead based on my original name/incorrect value). It makes sense that doesn't get updated if you edit/change the name, so I *think* that may have been my problem? I deactivated and deleted the flow, then created it again w/ proper names and now it's back to working order and the Challenge has passed. Can I get a whoop whoop? I'd like to buy everyone on the forum a nice tall beer! :-).  Thanks for your assistance - onward! 
Debabrata BeraDebabrata Bera
User-added image

User-added image

This is work like bingo....
Thomas Smith 61Thomas Smith 61
This is still a problem and it is August! Just spent 5hrs on this issue with names on the Flow... 

thanks Mohammond Anis for the info!
Karen Sos3Karen Sos3
I made this and it works.
User-added image

User-added image

In this part I had the same problem whit "Upload_File" and didn't leave save the screen, well what I made is delete the red row.
User-added image
Finally mi screen works and can save the flow.
User-added image

I hope this works for everyone.

Same issur for me as well, so removed the upload file screen and followed as per the link and now working fine for me.

Ana Karen HernandezAna Karen Hernandez
Thank you Svel!!! I finally passed the challenge (afetr 2 hours) with the link you provided :)
Vincent O'DonnellVincent O'Donnell
I am not even at the challenge part yet, I am still inside of this module (
and have created the 'Quick Account' flow as prescribed and placed it on the home page. 

I am on this step
5. To see your flow in action, go to your Home page.
Click Back to return to Setup.
Click , and under All Items click Home.

When I go to the homepage, I am getting this error: 

We can't launch this flow because of a variable error. Send this error message to your admin. The value null is being provided for variable accountId but isn't compatible with the variable's data type (String). Check the places where you implemented the flow ‒ such as through a Lightning page or a custom button ‒ and make sure that all provided values are compatible with the variables' data types.

We can't launch this flow because of a variable error. Send this error message to your admin. The value null is being provided for variable accountId but isn't compatible with the variable's data type (String). Check the places where you implemented the flow ‒ such as through a Lightning page or a custom button ‒ and make sure that all provided values are compatible with the variables' data types.

It is something to do with the accountId variable within the flow having a null value? Please help!
Rangababu Ch 7Rangababu Ch 7
@Chris Duarte - I'm unable to finish this challange.. even I completed all the mentioned steps. The error message is Can't find 'Last Name' and 'Company Name' screen fields in the 'New Lead' flow. But actually in my Flow those fields are avaiable.
Victor GanenVictor Ganen
That solved the issue. Thank you!!
Deepthi T 28Deepthi T 28

I am not able to finish the challenge.Please check below error
Challenge not yet complete... here's what's wrong:
Can't find the 'New Lead' flow in the 'Process Automation Home' page. Make sure the Developer Name of the page is 'Process_Automation_Home'.
Arun battulaArun battula
I have come across with same issue, and solved it.... you might have put Upload_Flow as the second Screen name. If that is the case it won't allow you to make the Unique Field Name as Upload_Flow for reference follow the link,
Artur SviridovArtur Sviridov
The problem: Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'  SOLVED!!!

Today 4th March and the problem still exist!
The second Screen unique (API) name should be: "Upload_Files" and Lightning component field unique(API) name should be: "Upload_File".
The label name for Lightning component may be anything you want.
I spent 3 hours on this issue. Thanks, guys for answers.
Chris DuarteChris Duarte
We are checking for the component field API name only. It needs to be Upload_File.

We do not check for the screen API name. It can be anything you want.
James McDonald 1James McDonald 1
still doesnt work
Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
James McDonald 1James McDonald 1
My Flow works perfect but the message below is still comming up. I have used Upload_File and UploadFiles. Removed old version and reproduced it about 6 times now with the same error.

Challenge not yet complete in My Trailhead Playground
Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
joseph djoseph d
I stilll get this error, please advise what to do , i followed instructions posted here and no fix. 

Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
James McDonald 1James McDonald 1
I was able to complete the challenge by changing the name of the Edit Screen to UI_File and then change the File upload component on the screen to Upload_File.

 flow builder

I don't think the instruction clearly state what needs to be call Upload_File but this worked for me.
William JeffersonWilliam Jefferson
Does anyone have a walkthrough on how to complete this in Lightning? I've been stuck on it for days and I'm lost
Seems SharmaSeems Sharma
Hi William Jefferson, you only need to follow steps of challange  and create a flow.

1. First create a flow
User-added image
This will throw warning when save this flow "These issues don't prevent activation, but can cause problems when you run the flow. Component_Screen (Screen) - This screen includes screen components that require Lightning runtime." Just ignore this warning and 
activate this flow.

2. Create a ligning Page  
Setup -> User Interface -> Lighning app Builder -> new 

User-added image

Now ,successfully complete the challenge.

User-added image
Rishi VardhanRishi Vardhan
The problem still persists, I am still unable to activate the flow becaue it keeps giving the warning. 
User-added image

Can someone advise how to proceed on this.
Kenneth Ries 6Kenneth Ries 6
Go to the Flows page and activate it there.
Quick Find -> Flows -> New Lead (flow label) -> Activate (under the "Flow Versions" section)
deep kaurdeep kaur
Please help me to resolve this issue
Sammie CooperSammie Cooper
Hi I am still receiving this error in 2022 but thr fix link no longer works. Could anyone help?