function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Nidhi Singh 41Nidhi Singh 41 

certificate and key management - keystore import issue


I'm trying to import my HTTPS certificate into Salesforce and once I click 'save' after uploading my JKS and keystore password, I just see the below. error though I'm an admin user with the 'Manage certificates' permission set in my profile page.

Data Not Available
The data you were trying to access could not be found. It may be due to another user deleting the data or a system error. If you know the data is not deleted but cannot access it, please look at our support page. 

Can anyone suggest me how to fix this?

Hi, Did you fix this issue? I'm facing the same  problem ....

I tried importing the JKS certificate in different orgs and only happens in my developer edition recently created. i.e., in other developer editions works.

I tried checking the profile permissions, but I logged with System Admin with all permissions granted.


Anybody help, please


Mahesh D 13Mahesh D 13
Hi, Getting same issue in a Scratch org. did you get to fix this.