function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Michael Markel JrMichael Markel Jr 

Set up and manager shield platform encryption trailhead

I have tried the recommendations from other posts on this topic. I have created a couple of new DEs to try this out in. I set up the permissions correctly for my account. I added the fields and attachments to be encrypted but when I go into a contact or case the fields are not encrypted. I double-checked to make sure that the System Administrator does not have View Encrypted Data checked and all permission sets assigned to my user also don't have that option checked but the fields are still not encrypted and the trailhead is not validating, I keep getting the error 'The contact mobile phone field does not appear to be encrypted.' I also tried adding new contacts and cases and editing existing ones but still not encrypted.
Best Answer chosen by Michael Markel Jr
Gustavo TandeciarzGustavo Tandeciarz

All Answers

NagendraNagendra (Salesforce Developers) 
Hi Michael,

May I request you please provide a screenshot of the following so that we can look into it and do the needful accordingly.

1)"View Encrypted Data" checkbox for System Administrator Profile
2)List of permission sets associated with your user
3)"View Encrypted Data" checkbox for each of those permission sets
4)Platform Encryption page.  Setup -> Security Controls -> Platform                  Encryption
5)List of Encrypted Fields 

Michael Markel JrMichael Markel Jr

Here are the screenshots:

1. User-added image
2. User-added image
3. User-added image
4.User-added image
5.User-added image


Gustavo TandeciarzGustavo Tandeciarz
I just wanted to mention that I am seeing the same problem.  I get the same exact error and symptoms (I enabled plat encryption on a brand new dev org, created the key, added the fields, created a new contact, etc.  I can see the field value even without the permission "View Encrypted Data".

This is either an issue with the platform encryption product or may be specifically related to Spring 17.  Not sure the cause, but the end result is that I cannot complete the challenge. 
Gustavo TandeciarzGustavo Tandeciarz
Oh, by the way, I know encryption is enabled because when I open up dev console and try to filter on the encrypted MobilePhone field, it gives me an error (appropriately so) stating that I can't filter on that field.
Gustavo TandeciarzGustavo Tandeciarz
Also, I created a new encrypted field (using classic encryption) and that field displays as encrypted.
Gustavo TandeciarzGustavo Tandeciarz
Looks like as of Spring 17, this is broken.  This feature is auto-enabled on new Spring 17 DE orgs and doesn't look like it can be disabled.
User-added image
Gustavo TandeciarzGustavo Tandeciarz
This was selected as the best answer
Michael Markel JrMichael Markel Jr
Thanks Gustavo, at least that makes sense. I guess I will wait for them to update the Trailhead trail and then finish the challenge.