function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Krishna RamaKrishna Rama 

" An internal server error has occurred" - While Assigning Apex Classes to Permission Sets

Hi All,
We are receiving an internal server error. when I go to (any) Permission Set, Apex Class Access then hit 'Edit' we are facing this issue. How can we overcome this, please assist.

Error: An internal server error has occurred An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience. Thank you again for your patience and assistance. And thanks for using! Error ID: 1488824837-18844 (-1270687048)
Amit Chaudhary 8Amit Chaudhary 8
Unfortunately there is nobody that mans the forums that has access to Salesforce's ISE error lookup tool.  
You will need to file a support case with Salesforce and provide them the error Id that you are getting to get more information

Please check below post for more detail

Chris Klassen 10Chris Klassen 10
I'm getting this same error in an org with a large number of apex classes.  Was there ever a resolution for this?
Ashwin KhedekarAshwin Khedekar
Two workarounds exist for issue of "Internal server error" while going to Profile and clicking on Edit for "Apex Class Access" (from Manage Users -> Profiles -> Profile Name)
1. Disable "Enhanced Profile User Interface". For this type "User Management Settings" in Quick Find box.
2. Do it the other way around. Go to the class for which access is to be given for a particular profile (from Setup -> Develop -> Apex Classes). Click on the "Security" button. Assign profiles from here to whom this class will be accessible.
James A QuinnJames A Quinn
For permission sets, where the profile workarounds don't work, I was able to resolve this issue by going to Setup >> User Management Settings, and enabling "Enhanced Permission Set Component Views"
User-added image
Manan Shah 15Manan Shah 15
Thanks James A Quinn. I was able to resolve same issue using your suggestion.
Soumya BeheraSoumya Behera
Thank you James! A golden comment from you!
Rahul SharmaRahul Sharma
Works nicely, thanks James! Sad to see this is still an open issue.
Vitalii Dehnerys 5Vitalii Dehnerys 5

I have got similar issue when I am trying to add Object Field access to Permission Set. 

Ihave tried James A Quinn suggestion, however I still get the issue.

Any workaround here ?