function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Agustina GarciaAgustina Garcia 

Can't create Lightning Components via Eclipse (beta)

I have followed these instructions to install beta version in order to develop Lightning Components in eclipse, and I'm able to create a project and retrieve those files that I already created on this organization. However if I try to create one, I get this error message

User-added image

And afer clicking ok this one where field to set the name is blocked.

User-added image

I tried several times to set credentials just in case but no luck.

In addition, if I try to modify an existing component and click on "Save to Server" link, I get also this error:

User-added image

Any clue about this?

SandhyaSandhya (Salesforce Developers) 

Ensure that you are using the proper security token! If unsure, generate a new one. This should help.

Eclipse error: “unable to perform synchronized check with remote server”

Try the below steps.

1. Right click on your project.
2. Go with>Deploy to server.
3. You get the error here.
4. Re-enter the credentials - and if it still does not work you have 2 approaches.

2 Approaches:
1. Use any other user's credentials to see if it actually works.
2. Create a new project with a different name, make changes and deploy.

Please refer below link for more information.
Hope this helps you!

Please mark it as Best Answer if my reply was helpful. It will make it available for other as the proper solution.
Thanks and Regards

Agustina GarciaAgustina Garcia
Thanks for your answer it is a good solution but that helped just on half. I already entered credential several times and token was also fine.

But I checked with another project (nothing related to lightning components) and it doesn't save to server either. So something related to the

Any other idea?
John TJohn T
What version of Eclipse are you running?
Agustina GarciaAgustina Garcia
Eclipse Mars 4.5.2
John TJohn T
Are you connecting to a Dev Org, or a Sandbox?
Agustina GarciaAgustina Garcia
Developer Org.
John TJohn T
OK.. I'll suggest that you try this.
  1. Log into your Dev Org
  2. Try to save something from Eclipse to the Server
  3. Switch back to browser and check your Login History. It should look like this
Login History Screenshot
You *might* see something like "invalid password", or you might not see any evidence of the Eclipse Plug-in trying/succeeding/failing to login.

Any chance you have a permissions issue?
Agustina GarciaAgustina Garcia
Fuss, thanks for your help.

It's quite wired, actually. I opened eclipse and tried to set loging details again via Property in Eclipse, to be sure that it was al fine. And it seems to be because this is the first entry in Login History

User-added image

But then I started getting these issues in eclipse. Several although I only have one here:

User-added image

After that tried to modify a Lightning component and save (ok) and then save to sever and check loging history (first screen) and it is when I get Invalid Password but it doesn't make sense because I logged in the org and modify Property files with the same one and all it was good.

Something else that I checked was to specify different  loging URL (due to MyDomain) but same result

User-added image

How can I check permissions? That was your second guess ....