function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Mohammed GheitaMohammed Gheita 

Users unable to login to the Salesforce Mobile app for Android or iOS through Single Sign On

We have configured single sign on and want users to login to salesforce through SSO when using the salesfrce mobile app. Users have installed the salesforce app on their mobile device and when they click the single sign on button, it asks users to 'To enroll your device, install the free Microsoft Intune Company Portal app'. However the Intune app is already installed by default for users in our org.
Has anyone else had this issue or something similar when trying to login to the salesforce mobile app and figured out a workaround?

Steps followed to reproduce:
Method 1 : Login with username and password (Salesforce credentials), works fine.
Method 2 : Go to Salesforce Mobile app

• Change the custom domain to company name, so we get the SSO button to appear on the mobile app and login through SSO
• When we click the SSO link, it redirects to Microsoft login page.
• Primary authentication is successful, and we are receiving an authentication notification on Microsoft Authenticator.
• On clicking on Approve, it re-directs to Play Store to install Microsoft Intune Company Portal.
• Microsoft InTune is already installed on the Mobile Devices.
• Devices tested : Windows 10 laptop, Android Mobile Device, Iphone.
We have tried the following:
  • Deactivated Google Chrome on Android device, no luck with the default browser.
  • Updated the InTune policies, no luck.
  • Windows 10 device is updated with the latest sync policies, no luck.
  • Checked the domain settings in salesforce to 'Use the native browser for user authentication on iOS and Android'. No luck.
  • We raised it with our Microsoft team to investigate. They have indicated that it is an issue with the salesforce mobile app.
Any info would be much appreciated. 

VinayVinay (Salesforce Developers) 
Hi Mohammed,

Try steps mentioned below.

Hope above information was helpful.

Please mark as Best Answer so that it can help others in the future.

jacob martin 9jacob martin 9
Well!! consider connecting with the right mobile app development company ( in order to solve your issues. 
hs dsd 10hs dsd 10
The workaround is to reload the App when you get the error - for Android ( hit the 3 dot menu and click Reload, for IoS hit the Settings Cog and re-choose your Production or Sandbox connection - this reloads the App in IoS.
Hi Mohammed Gheita,
Any solution found, facing similar problem. Please let me know if any, it would be great help for us.
Jared PabloJared Pablo
Click New. Select the Field Service Mobile license from the picklist. Click Save. Click System Permissions, then click Edit.
Assign the permission set to your mobile app users.
Click Manage Assignments, and then click Add Assignments.
Select all users who need the app permission set as you should know why is safety important (
Click Assign.
Ethun HuntEthun Hunt
Thank you for your solution! Keep visitng my website on WhatsApp Mods (
Elia LeoElia Leo
Here you got some solution of your problems now To double your enjoyment and experience, you can also download the Pikashow App on your PC.