function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Salesforce accessibility/login problems with Ubuntu Linux

Three or four days ago, I started experiencing difficulties logging into Salesforce from Linux (Ubuntu).  My machine is dual-booted with Windows Vista, which was not having any problems logging in.

Firefox 3.5.5, Chrome Beta and Opera 10.00 all reflect the same problem, which originally led me to believe that maybe there was something in a recent Linux update (however unlikely) that caused the conflict.  I couldn't find anything out of the ordinary as I was able to navigate all other sites just fine.  The only sites I had any problems with at all were the ones on the Salesforce domains (i.e.,,,, etc.).  When I would go to, it would just spin forever and never resolve.  I am able to ping these subdomains just fine and lynx (text browser) doesn't appear to have the issue so much.

Today, I tried clearing all cache and cookies from the three browsers and tried again.  I was able to access the page once in each browser, but when I put my credentials in, it would never actually redirect me to my org.  I tried this with multiple orgs with the same result (clearing cache and cookies before each attempt).  If I fail to clear the cache and cookies and try to load the login page a second time, it will not resolve.

To further compound this oddity, I was able to successfully login to a couple orgs by explicitly specifying the node in the login URL (i.e.  I have been playing around with the cookies that are created during these sessions and the problem seems to reside in the "" domain set of cookies.  Each subdomain has its own set of cookies (i.e. these community boards store cookies under the "" label) which don't appear to be the root of the problem.


The only way I am able to login and make this post was if I keep the cookies window open (I'm using FF at the moment) and delete the "" folder whenever it popped up.  The "" folder remains and doesn't appear to be causing any harm from what I've noticed so far.  In Ubuntu, I am only able to get as far as creating this message.  In order to post it, I've had to switch to Vista, paste what I wrote in Ubuntu and press the Post button from here.  Ubuntu would not complete the posting transaction.

This still may be some obscure bug in my own configuration, but I figured I'd throw it out there to see if anyone else was experiencing similar symptoms.


Not like it will answer your question but I am running Firefox 3.5.5 (and Iron [Chrome derivative] ) on Ubuntu 9.10 (Karmic) without any issues.


Both FF and Iron work just fine with SFDC (Prod, Sandbox, Community) 


Ubuntu updates are up-to-date.

Message Edited by gaiser on 12-11-2009 01:06 PM
Which leads me to believe that, most likely, it is a problem with some sort of configuration on my end then.  Thanks for the info.  I guess it's reassurring that this doesn't affect all Ubuntu users :)
Lee GoldinLee Goldin
I tried to login to Salesforce via Ubuntu and since it was a new workstation I hadn't used before it asked me to verify via SMS. Fine. But while those SMS verification messages usually come in almost instantaneously they simply didn't come. I tried again and eventually was locked out. I called Salesforce support but was told there was no way I could get back in until I waited an hour. I explained that this wasn't my fault and I should be able to access my instance but they had no power to do anything. An hour later 5 SMS messages came in in quick succession. Since this has never happened in Windows or OSX I can only assume it's an issue with Ubuntu. I will never try and log in using this OS again. Unacceptable.