function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Installing IDE into Eclipse failure

I first tried installing the IDE plugin into RAD since that's what I already had installed.  For some reason, it couldn't actually open the perspective.


Then downloaded and unpacked the Eclipse 3.5.2 package.  I added the Force site to Eclipse and it started the plugin install.  However, about halfway through it failed with a repeated error:  "unpack facility not configured" for every package.  Running on XP.   Any suggestions?



Best Answer chosen by Admin (Salesforce Developers) 

Or even have the IDE be open source so we could troubleshoot the issue. I've created such an idea here.

All Answers




Try Eclipse 3.4. There have been issues with the IDE on the newer version of Eclipse.




That was a good call, as the 3.4.2. Eclipse was more accommodating during the plugin install.  However, after restarting Eclipse and trying to open the Force perspective, it returned the same error I saw in RAD, basically saying it couldn't open the perspective.  I then went into Preferences and tried to access the options.  That also failed with a more useful error, which sounds like it relates to the first error:


Unable to create the selected preference page.

An error occurred while automatically activating bundle com.salesforce.ide.ui (181).


I'd also tried to install the standalone version of the IDE but that failed early on with


An error occurred while collecting items to be installed
  session context was:(profile=com.poweredbypulse.profile-996782-rmb-1003709,, operand=, action=).
  Could not find repositories containing the following artifacts: [osgi.bundle,org.eclipse.draw2d,3.5.2.v20091126-1908, osgi.bundle,org.eclipse.emf.common,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.common.ui,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.ecore,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.ecore.change,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.ecore.edit,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.ecore.xmi,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.edit,2.5.0.v200906151043, osgi.bundle,org.eclipse.emf.edit.ui,2.5.0.v200906151043, osgi.bundle,org.eclipse.gef,3.5.1.v20090910-2020, osgi.bundle,org.eclipse.wst.common.project.facet.core,1.4.1.v200911141735, osgi.bundle,org.eclipse.xsd,2.5.0.v200906151043, osgi.bundle,org.eclipse.xsd.edit,2.5.0.v200906151043]

Cut off at every pass, it would seem.






Very confusing. So you've:



  • "installed" a clean version of Eclipse and the IDE?
  • don't have a proxy?
  • are using windows?
  • are using a fresh workspace?
  • have cursed the heavens in frustration?



All of the above.  When I get the chance I think I'll remove every trace of everything relevant, reboot and try again.


So a reboot solved nothing on this machine.  I then tried on a test machine running Vista Business.  The standalone install failed in a different way.  Installing the plugin into an Eclipse 3.4.2 finally worked there. 


It would be nice if these applications had errors messages that actually provided information that would help understand the problem.


Or even have the IDE be open source so we could troubleshoot the issue. I've created such an idea here.

This was selected as the best answer

Thanks for your input.


I got a similar message while installing the Force IDE into Eclipse 3.5.2.


No repository found containing: bundle org.eclipse.wst.common.project.facet.core


To resolve the dependency, I installed the latest version of the Eclipse WebTools framework.  It's available at


Hopefully this will help someone else in the future.