function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

No custom colors with FORCE IDE?

I use a dark color scheme with debian and it's made it difficult to see the eclipse IDE (force IDE). Is there no way to customize the color settings? Seems silly, as *every* other editor I use allows this.


May be this will help you.




Don't know if it's just my browser (Iceweasel) but I didn't see that link above at first.


Well, I tried using those color options, but I couldn't find one that matched plain text. Here's a screenshot of my current IDE with my color scheme on:


RJ PalomboRJ Palombo

I'm getting the same. Any luck with this?


This remains an issue still. If anyone has a workaround it would be greatly appreciated.

Anything new happen in regards to this yet?
Kelly KKelly K

I don't know if they've fixed the IDE yet, but I highly recommend using Eclipse with the plug-in. I use it because it does allow font customizations (I can't stand huge text..)


You'll need to use


  1. Whichever version of eclipse you'd like (I currently use Kepler), though only Eclipse Helios is Salesforce's recommended version
  2. Java JRE or 6u27 (can use JDK, but only JRE needed) - any other version of java causes some odd errors with the plug-in
  3. Add the Eclipse 3.8 Update site to installed software (needed for dependencies for Juno & Kepler) at
  4. Install the IDE plug-in.

If you need more information or get stuck along the way, message me and I'll send you some more formal instructions that I've given to my other administrators for installation.



I think there might be some confusion... the original poster said he was using the Eclipse IDE and could not get his dark color theme to display properly.

I already am using the Eclipse IDE but there is no way to customize the colors in it, that I can find. I tried using the Eclipse Color Theme plugin, but I too was receiving very dark theme colors regardless of what I chose.
The issue is on Eclipse as well. It's not an issue with the IDE itself but with the theming plugin.
Kelly KKelly K

So I tried this out earlier today and found the same results.


It appears that a request has been put in at github which they report that there's no support for changing colors on Apex editor files.


Here's an idea that you could vote on and hopefully Salesforce will get around to it.


While they're at it, I hope they enable it for their new Dev conosole... the font on that makes me feel like I should be developing from the other side of the room.


Otherwise it looks like your best bet at this time is to manually go through and update everything in the Color & Fonts section.

Ironically I had found both of those sites as well :-) but I agree we should vote for that feature for both the IDE and the Dev Console!

I started updating the Colors And Fonts manually but you cannot quite edit it enough... at least we can change the font size right !