function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

RUBY : Custom object namespace prefix problem

I have a custom object defined with a namespace/custom prefix : the resulting classname is something like ALT__Myklass__c

I wish to define Myklass in ActiveSFDC :
class Myklass < ActiveRecord::Base
    include ActiveSalesforce::ActiveRecord::Mixin
This does not work : ActiveSFDC looks for ALT_Myklass (notice only 1 underscore), or defaults back to ALT_Myklass__c (still only 1 underscore). This does not work either if we do not set_table_name : AsctiveSFDC goes llooking for Myklass__c, with no prefix.

ActiveSFDC needs to handle namespace prefixes correctly, just as it handles custom '__c' suffixes.
Doug ChasmanDoug Chasman
I am looking into providing namespace support now. BTW Rails' is bound and determined to eat underscrores - this has caused me no end of frustration!
Brendan LallyBrendan Lally
any movement on this.

I also have the same issue (as using namespace for a managed Appexchange package)
Tried the latest gem and no go.
Looks like an issue in reflector?

+1 for this request.

Could somebody from the development team please respond, even if it is just to indicate whether it is being actively worked on or not. It would be great if I didn't have to spend time looking for a workaround only to discover a solution was imminent.

thanks a lot



Any changes on the status of this?



thanks in advance!!