function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

curl_exec error 60


I'm testing enterprise Edition of Salesforce to try to manage some of the data from salesforce externally from our web site.

I have done step by step everything explained in the "Using sforce with PHP".

My web hosting provider don't have installed SOAP and they aren't going to install it, so my next option was to install an Apache, PHP, and everything on my own computer and make it work as an internet server.

After installing every file of the PHP example and execute it I introduce the "username" and "password" in the login.php form and I obtain the next result:

Error: curl_exec error 60 SSL certificate problem, verify that the CA cert

I have reinstalled PHP, but the error it's still the same. (I saw over the board that some person had the same error, but the "solution" was to reinstall, and please note that I'm running my own server on a LAN, so maybe my problem it's different)

What is happening? Any solution? What I'm doing wrong?

the example files are from:

Best Regards,


This URL sums up the problem and potential solutions best:

Basically, the SSL certificate SalesForce is using is not signed by an authority the curl library recognizes. I had the same problem on my local setup; you can do a quick kludge by putting the "curl_setopt( $ch, CURLOPT_SSL_VERIFYPEER, 0 );" line in SOAP/Transport/HTTP.php; put it right after the curl_init() line (should be line #548) in function &_sendHTTPS, and you'll be all set.

This is not the ideal solution though, but it saves you the hassle of trying to get the certificate loaded up just for initial testing purposes.

*** EDIT: A somewhat better solution would be to download the CURL package for your OS from, extract the curl-ca-bundle.crt file, and then use this line after the curl_init() line:
curl_setopt($ch, CURLOPT_CAINFO, "C:\path\to\curl-ca-bundle.crt");

I still am not crazy about this solution as it requires adding a line into the SOAP library, but it is better than turning off verification completely.

Message Edited by sprak on 02-27-2004 06:44 AM

Thanks, now it seems to work fine!
It's at line 553 in the latest SOAP (downloaded 12/22/2004).