function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Package install fail: missing feature apex class

I have a new native app on the app exchange and a professional edition customer tried to install it. They got a bunch of errors like this:


Missing feature

Apex Classes

Installing this package requires the following feature and its associated permissions: Apex Classes



My app uses a few custom classes, objects, and a visualforce page. I was told that even a pro edition can install an app that uses custom apex classes. 


Does anyone have ideas of how to dig into this further?




I'd log a ticket with  Sounds like your application is not enabled for install into Professional Edition with apex code.  




Thanks Andrew,


Do you know what I should ask them? I've been exchanging email with support (not sure which support but I do have her name) and she said there was no way to do it. But we were told there was and it sounds like you're saying it's possible too.


Any thoughts on what I can ask that she do? Any particular setting they need to configure to allow installs into group and pro?





Can you post your case number?  I'll follow-up.




Thanks Andrew,


The case is 02458299 and we'll try the other link you gave as well for apex!






Were you able to get a solution to this? I am stuck at exactly the same issue. My app is ready to be rolled out and unfortunately it cannot be downloaded on the Professional Edition.


Any help is MUCH MUCH appreciated. 





Hi Mukul,


To install an app with Apex in professional edition, your app has to be a managed package that is certified.  Only partners that meet the necessary requirements can have their app certified.  First step to becoming a salesforce partner is to join the partner program.  Then log a case through the partner portal and they should be able to help you.





Thanks for the reply Andrew! I am already a partner with Salesforce. I will log a case and let you know how it goes.





Hi Andrew, I'm a professional edition user and am running into the same Apex errors when attempting to install this AppForce Labs app:


Any ideas why this might not be working correctly?


Thanks in advance.



This app requires your edition to support apex code.  Professional edition doesn't, so you won't be able to use this app.  You'd have to upgrade to enterprise edition.



I've seen two replies here from you.  One says you need to upgrade from Professional, while the other says the App needs to be managed.  Will either solution allow an application to work?


My scenario is that I am testing an unmanaged application at the moment.  If it becomes a managed app, will it work on a Professional Edition of Salesforce?


I am having the same problem:


Missing feature Apex Classes Installing this package requires the following feature and its associated permissions: Apex Classes


I am running the trial version.  Is the trial version not enabled for this?




I have the same issues and questions as well.  Judging by all of the conflicting statements I've seen, access to the Apex Classes in Professional is dependent on the phase of the moon.  Or something.


Time to start the paperwork for an Aloha App, I guess...


Jerry (Not A Happy Camper) H.


From the DeveloperForce article, "Designing an Application for Group and Professional Edition" (


Apex Authorized

As a general rule, one cannot run Apex in a PE or GE. However, there is one exception to this rule. Apex that you develop in DE can run in GE and PE, if the following conditions are met:

  1. Apex is installed into the GE and PE org via a managed package.
  2. Apex does not expose classes as a Web service - these can be installed, but not invoked (more below).
  3. Apex is not dependent on features and functionality that exist only in EE or UE (e.g., record types and/or Campaigns) unless it's dynamic Apex.
  4. Your app and Apex have passed the Security Review and been "Apex Authorized."

Apex Authorization means that Apex (classes, triggers and email services) in your app will run in GE and PE, even though those editions do not support Apex by default. It is important to note this does not mean the GE or PE customer can create new Apex or modify Apex in your app. They can only run the existing Apex in your app. As noted above, any Apex classes that have been exposed as a Web service cannot be invoked from an external Web app in GE or PE even with this special permission.

To be clear, let's say you also host a separate Web app that needs to call an Apex class in your app. You might expose one of your Apex classes as a Web service and include it in your managed package. For DE, EE or UE, you will be able to invoke this Web service externally, but in GE and PE, it will not work.

However, using Apex to make Web service callouts is allowed in GE and PE. For instance, if you are planning to make a Web service callout to an external Web service like Google, as long as the managed package is authorized, these classes will function in GE and PE.



Just a quick add on, if I may....


We are still in our 30 day trial period and we're on an Enterprise platform.  We just tried installing the Round Robin Assignment tool by and upon unpackaging:  Package install fail: missing feature apex class


I am an administrator with full rights.  Can you think of any reason why I cannot get this installation to work?


Appreciate any help you might be able to provide.





The 30 day trials do not support Apex code.  If you purchase Enterprise Edition, you can then install this app.  If you want to try it out beforehand, sign up for a developer edition org at  Then install the app into that org.  That will allow you to try it out before purchase.






Hello Andrew,


I'm evaluating Customer Cloud and signed for a trial. When I wanted to test VersionOne integration and install the necessary app (VersionOne CaseConnect) I run into the 'missing feature apex class' error.


As I understand (based on your comments), I cannot do that in trial, as it does not support it.

I have signed for a developer edition as you recommended, but now I'm facing new errors:


Duplicate Name The name "XMLDom" is already used on component type: Apex Class. Please rename existing component.
 Duplicate NameThe name "Case.Product__c" is already used on component type: Custom Field Definition. Please rename existing component.


Any idea how should I proceed? Do you think I could test this app somehow before purchasing anything?

Thank you in advance!





Chirag MehtaChirag Mehta

I'm trying to install a MANAGED PACKAGE from my developer org to TRIAL Professional Edition, and I'm recieving

Installing this package requires the following feature and its associated permissions: Apex Classes


Would this error still appear if I install the package in a Professional Edition (not trial)?



I don't know the specifics of your situation, but you might be able to find the answer to your question on the page above (the Appendix is especially useful).  It might be a simple case of the customer not having enough Salesforce permissions (e.g. not logging in on an Administrator account) to install your addin.


You might want to open a support case and have the Salesforce engineering support staff take a look at your addin to see if there's something specific (SOAP services, web service calls, something of this sort) that would prevent installation on a Professional Edition environment.


Jerry H.


Yes, it would.  Only apps marked as Aloha on the appexchange can be installed into PE orgs.  


> Only apps marked as Aloha on the appexchange can be installed into PE orgs


Does this mean the following information from "Architecting a Commercial Application" (link provided above) is incorrect?


"Native apps can be authorized, which means that the Apex Code in the managed package can run in Group and Professional Editions, growing your potential customer base."


Jerry H.


Aloha and "authorized" are teh same things.  We'll be updating this doc to reduce the confusion.  


Well I was trying to install iCalendar Export 1.2 into my PE salesforce and it is listed as an aloha app in appexchange but I am getting the same error when I try to install. So is the statment about the aloha apps not always true to be able to install in the Professional Edition...


Been referred to this thread regarding an apex class issue and am still confused.


We are currently running Enterprise and I (with the help of others) crated an apex control class  with an accompanied page. We are shortjly merging with a larger company and they run professional.  I need this class to run in their professional version.  What do i do?  Do i need to beceom authorized and then push the app via the store?


What are the steps?


THank you


Thanks for nothing

Koen (BvD)Koen (BvD)
Hi everybody,

I am stuck on a similar case. For all that I can find our package should install on PE (registered partner, review passed, appexchange listed, no enterprise functionality used etc). Still a client with PE has the exact same error message (while they have a previous version of the package installed. 

I opened a case (there is no longer a case category to get aloha for a package as according to my findings this should now be automatic) but it isn't leading to much (except a few exchange of fragments of documentation I already read before opening the case).
So if someone here has a suggestion of what else I can try, I would be happy to hear it.


PS: my open case number is 10532188