function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Can't restore, recreate or edit a class in a managed package

We have a Salesforce integration implemented as a managed package. I have some test classes which provide test coverage for the apex code in the package. Yesterday I was attempting to move the test code into the classes the test code covered. I copied the test code, deleted the class "TestRecordTypes," and created a test function in the controller class. After running the test, code showed as not covered even though it showed as covered when the test function was implemented in a separate class.

When I tried to move the code back into the class I was unable to edit or recreate the original TestRecordTypes class. If I create a new class w/ the same name in Eclipse the original code shows in the newly created class (???), but if I try to save I get prompted w/ "Remote instance has been updated... Use synchronize perspective..." but the synchronize perspective won't let me save the restored code in the deleted class.

I tried to delete the class using the API, but I get a message like "The class is not deletable."

So, the deleted class still shows in Setup / Develop / Classes. I can't edit it, or make it go away so I can recreate the class

This is bad enough, but when checking for responses today I find my original post was deleted.

Does anybody have any input on this one?