function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Packages Seem Flakey Since Spring 09 Release.

Does anyone else find that they are getting a number of Package Upload and Package Installation Errors since the Spring09 release? Seems like ever since then we have been plagued by all sorts of issues that force us to go to Salesforce Support to get them resolved.


It has probably happened to us about 5 times now where we get an error like this:

If this error persists, contact Salesforce Support through your normal channels and reference number:  xxxxxxxxx-xxx (-xxxxxxxxx)


If we are doing something wrong, salesforce won't tell us and it's really making us look bad when we can't follow through with customers because of some unknown error that we apparently can't fix on our own. Then we have to wait a week to get it resolved.


Just wondering if this is a problem anyone else has been having since Spring 09, or if it's something directly related to the way in which we build and deploy these packages. (or maybe both)


I was about to write the same type of message and I saw yours.  This is exactly what has been happening to us.  We are losing face with customers too since they can only hear the "Salesforce will fix it" line so many times before they think we are incompetent. 


I have noticed this more and more since Spring 09 as well.  Hope they find some resolution here as now all of a sudden all VF pages deployed in my package have stopped working for a group of my customers while it works fine for others.  The message is very obscure and displays something like "This web page is being redirected to a different location".  Seems to want to send my VF page to some place on


The URL has moved <a href="">here</a>



I Know, Right?!?!? :smileysad: Nice, and sad, to know we are not the only ones.


Funny you mention the VF Pages because we just bumped into something similar there as well.  One new customer installed one of our apps and the VF pages could not be found when user actions should have led to them.  Customer could see the VF pages were installed and even see the code, but the links/buttons/VF-Tabs all lead them to an error that said they couldn't be found.  Customer actually had to open our VF pages in their org, copy the code, and then build their own VF pages with the same name and paste the code in there to make things work again. It installed and worked great in their sandbox though. Something is not right.  That customer was in Europe, so I was wondering if that had something to do with it... but I'm really just guessing there.


Maybe this has something to do with Eclipse and the plug-in??? 


Only they could possibly know and no one is talking when I ask them how I can prevent this in the future.  Would be nice if it all magically went away in June when they upgrade us.


Can you post the error id?

Support repaired the package. 


I found the salesforce bug that was giving me fits and destroying my packages, recorded it using Camtasia and submitted it to support.  It got viewed 5 times in the first 5 minutes after sending it (according to the IIS logs) and was told they were seriously looking into it and should have it solved in the Summer 09 release.  I will test it again next Monday when the release hit the development orgs.


Bug basically had to do with a duplication visualforce controller classes with different namespace capitalization when creating the controller from the red "Create" links that appear in the VF editor, then going to view the VF Page.


My guess is that it resulted in a big "Oh-Sh!#!!" moment for some developer. LOL!  But I like to think that we have all been there before.  ;o)


We started seeing some pretty strange behavior when extending/deploying packages lately, and then I ran across this thread, which is the closest I can find to something that resembles the behavior we are seeing. Is anybody out there seeing stuff like the following problem:


In a customer sandbox, we're using a VF page that uses a global a component of a managed package. Some times after reinstalling the managed package, we're getting a 'URL No Longer Exists' error when we go to the VF page for the first time. In IE7, this happens more frequently. The VF page is in the sandbox, not in the managed package so it always exists. The error almost always clears up after a page reload. The VF page does not use a controller. The VF page only calls the components of the managed package.




I'll send you an email as well.  I think the issue you're having is far different from what the other people are seeing.  Try this fix and see if it works... add this Javascript to your visualforce page (or like me, reference the code externally so you can update it in the future):



A4J.AJAX.XMLHttpRequest.prototype._copyAttribute = function (src, dst, attr) {
        var value = src.getAttribute(attr);
        if (value) {
                try {
                        dst.setAttribute(attr, value);
                } catch (err) {
                        //alert('Error with Salesforce: ' + err.description + '\nattr: ' + attr + '\n');



It may be fun to uncomment the alert to see the situations where Salesforce would have errored out.  Salesforce doesn't catch errors on this set of their code, so any faulure causes problems.  I'm not 100% sure that this is the correction you need, but something odd like what you described happened to us and we tracked it down to a javascript bug of Salesforce that impfacted IE more than other browsers.