function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Run All Tests in browser timing out?

Hi, I'm trying to do Run All Tests from the SF web UI (setup > Classes > Run All Tests) and it's just waiting for response for a long time, and seems to have timed out.  I've tried it twice and both times, after at least 20 mins or more, no response from SF.  I assume by this time that it has timed out?


In the past I've had trouble with this timing out under Firefox and Chrome, but it always worked in IE.  This time I'm trying IE but getting no love.


I have to do this in the browser and not Eclipse, b/c I'm testing a 3rd-party managed package, and those classes don't appear in eclipse.  We have a lot of code in here, but it shouldn't take 20 minutes!


BTW, this is a developer account that has already been upgraded to Summer '10. 


Any remedies out there?






You can try with "Opera" browser. But ultimately it depends on the Internet connection speed and the No of test classes.




Wouldn't you able to run the test even once?

Does it show the runing test Swirl or the page is in blank?




Yes, it shows the "swirl", but it just stays like that and never completes.  I waited for over an hour one time.


Bump.  We're seriously stymied by this.  I thought I could maybe get around this by installing another package from appexchange, which would cause all tests to run asynchronously.  But found out that upon deploy or package install, it runs all tests EXCEPT those in already installed managed packages.  And those are the tests we really need to run here.


We've tried dozens of times, with every browser available, and it never works.  Times out every time (or just never returns a result.)


So at the moment, we are completely incapable of testing our code against a managed package that has its own code.  This is a big problem.  Anyone out there got any ideas?  SF, any plans to provide an avenue for this?