function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Windows Vista and Mail Merge

I recently started using a new laptop with the fancy Vista OS, and have since been unable to perform a successful mail merge. I've read about some problems with this in Office 2007, but I have Office 2003 installed on this machine. I'm also using IE, not Firefox, for mail merges. I can't seem to find any help online, but I doubt I'm the only person who is experiencing this problem. Any suggestions?
Error message:
Naturally, the the file that it's apparently referring to ("Cannot create a file when that file already exists" ) does not exist.
Thanks for any help.
I am experiencing the exact same problem right now.   Help!  Anyone out there reading this?  I'll post an issue, I guess.
Same error for me, too. Any fixes found?
The issue I posted has been "escalated."  I'll be glad to post the fix when I get one.
Same here.
It is apparent that this issue is rampant, and I hope Salesforce is scrambling!  I'm sure the fix isn't as easy as turning off the default Vista "protected mode"....but has anyone tried this?

Conga Mail Merge On Demand (on the AppExchange) merges fine with Vista / Office 2007, and supports Firefox, Opera and Safari (Mac). It's 100% compatible with your existing templates, and this part of the product is free. Conga also does mass merging of multiple records, and merges from reports, campaigns or just on-the-fly searches of Contacts and/or Leads. You can also merge to Excel.  Now supports PE, EE and UE. Contact me for details.

Is this a free download?
There's a 30-day free trial for the full Premium version. After 30 days the feature set drops to "Basic" without a subscription.

Unfortunately, since my company does not use the "Campaigns" feature in Salesforce, this application will not work.  Thanks for the offer---back to square one!

"Package NameConga Mail Merge On Demand
Version3.0.1 Conga
DescriptionConga Mail Merge On Demand is the point-and-shoot solution for easy batch printing of mailing labels, envelopes and personalized letters directly from
Unable to install this package for the following reasons:
Missing feature Installing this package requires the following feature and its associated permissions: Campaigns"

Campaigns aren't required; it's a problem we discovered this morning with the managed application package. The install tries to add a button to a campaign, and fails if Campaigns aren't available. We should have it fixed in a few hours. Sorry!
On the same topic: CongaMark can you also remove the requirement for the "Products" feature (not standard in PE).

How do you remove a requirement?  I have a similar situation where a managed package cannot be downloaded due to the lack of "Products".  Is there any way around this?




The directions below worked for me!!!

Dear Jocelyn,

I looked into your case for you further and I found a solution that may solve your issue. I have attached it to this e-mail if you would follow the steps provided and then send me an e-mail if they solved your issue I would be more than happy to close this case for you. If this does not solve your issue let me know and we will continue to escalate.

Before upgrading to the new Mail Merge add-on that supports Windows Vista and Word 2007, perform the following steps. Note that you must be logged in to your PC as a Windows user with sufficient administrative privileges to change the settings described.

1.) Open your Windows Control Panel.

2.) Windows 2000 and XP users, click 'Add or Remove Programs'. Windows Vista users, click 'Programs and Features'

3.) Remove the program 'Salesforce Mail Merge' if it is present.

4.) Open your Internet Explorer Web browser.

5.) IE 6 users:

5a.) Click Tools | Internet Options to open the Internet Options dialog.

5b.) On the General tab click the 'Settings' button in the 'Temporary Internet Files' area.

5c.) Click the 'View Objects' button. The file directory 'C:\WINDOWS\Downloaded Program Files' opens.

5d.) Delete the following items if they are present: 'CMMHost Object' and 'SFCom Control'

6.) IE 7 users:

6a.) Click Tools | Manage Add-ons | Enable or Disable Add-ons.

6b.) In the 'Show' drop-down list, choose 'Downloaded ActiveX Controls (32 bit)'.

6c.) If the following items are present, select them one at a time and then click the 'Delete' button to delete them: 'CMMHost Object' and 'SFCom Control'

6d.) Click 'OK'.

7.) Close Internet Explorer.


See Also: ("Why is Mail Merge not working?")

Thank you,

Lorilee Walton

------ Your Question / Comment ------

We are running Windows XP for some staff and are able to use the mail merge feature in Salesforce just fine.

Since an employee received a new computer with Windows Vista, she is unable to perform a mail merge. We are using Office 2003. We have installed the Active-X controls that the page asked for, but we are continuing to receive this error in a pop-up window:

Exception: Failed to move template to results folder rename limit was exceeded (100): C:\Users\Alberta\Desktop\Salesforce Merge Results GFileOpps::ModifyFile Cannot create a file when that file already exists.

C:\Users\Alberta\AppData\Roaming\\OfficeToolkit\download\test reg form - David Horne.doc C:\Users\Alberta\Desktop\Salesforce Merge Results\5.17.2007\test reg form - David Horne99.doc

I saw an almost identical posting on the blog, but no response since 4/30/07.


For exciting new options in customization of your organization and integrations which help extend your functionality check out the over 300 applications currently available via AppExchange! has launched a new level of transparency into our system with Please share this important URL with your customers and partners.



Sent from Salesforce. experience success.


Bingo. Worked for me, too. Bänz
Did this solution fail to work for anybody else? I was pretty excited to see it, but after going through the process the error message was the same. Windows Vista, IE7, Office 2003.

I didn't have the Salesforce Mail Merge progam on my list of installed programs.
I deleted the specified ActiveX controls.
When I restarted IE7 and tried a mail merge, the error window was the same.
Vista and IE7 then went through the whole song and dance of prompting me to allow for ActiveX installation, which installed the two ActiveX controls I had just deleted.
After they installed, the end result was the same.

How frustrating.

I am having the same results as Jib, except I'm using Vista, IE7 and office2007.

I didn't have the Salesforce Mail Merge progam on my list of installed programs.
I deleted the specified ActiveX controls.
When I restarted IE7 and tried a mail merge, the error window was the same.
Vista and IE7 then went through the whole song and dance of prompting me to allow for ActiveX installation, which installed the two ActiveX controls I had just deleted.
After they installed, the end result was the same.

The only solution was to rip out the elements that we used to install on items that aren't part of the standard Professional Edition. With Conga, we previously added a button to Campaigns, and if you don't have them the whole install failed. We pulled it out, along with a couple of other offenders, and now it installs normally.

We removed it! Give it another try. Sorry!

Conga Mail Merge On Demand - AppExchange listing:



Hi Jib!

did you got it working?

i get a different error, the translation would be "Sistem call level is invalid"

The short answer is no.

I just tried this and it didn't work for me.  I have Vista and Office 2007.

I am still getting the same error as the other people on tis thread.




I've got the same failure message and worked through all steps with no effect. Then I made the configuration which can be found on
now it works.

ME GrayME Gray
Lorilee Walton,
We have two computers running vista.  One computer mail merging properly and the other is getting the same error message as shown on this original message.  I tried what you recommended several times but each time I go to merge it reloads the Active X files you recommend removing and then I get the error message.  It is strange b/c the other computer has these loaded with no error.  Please help.  Thanks
M.E. Gray
Hello, i had the same problem... just run the IExplorer as an administrator (it worked for me)...

hope it helps.

ME GrayME Gray
There is a solution and it is posted on Salesforce.  When you have IE open, go to tools, select Internet Options, select Security, select trusted sites.  Then you have to make completely trusted to use.  Also delete CMMhost Object and SFCom Control by by opening Tools, select manage Add ons, select enable disable add ons, under the drop down box, select Download ActiveX Controls (32 bit) and delete the two mentioned above.  Then when you mail merge next time, allow the download of these two items.  It worked but only after I made the site a trusted site.  Good luck.

I'm getting the same error (vista business, fresh install, no former salesforce software installed).

Exeption:Failed to move template to results folder rename limit was exceeded (100):C\Users\HRworks\Desktop\Salesforce Merge Results GFileOpps::ModifyFile

I followed the instructions "uninstall, delete activex, etc." but nothing works.

Any other solution for this annoying problem?

Thank you

ok, it's working now. just had to add * to the trusted zone in IE.

ME GrayME Gray
I am not an IT person but I wonder if you might search for problems by IE version.  I know that version 7 has had problems with many websites.