function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Apex Component not working


I created an Apex Component on Friday and it was working correctly. Today when I have tried to use it I am seeing the following error message:

Expression Error: Named Object: core.apexpages.components.cdk.ApexComponentRefHandler not found

I tried a few things but still got the error message. I have now tried to create another one, saved it and I did not change any of the default text that is automatically included when creating a new component. I then went to .../apexcomponent/test to continue working and the same error message is showing.

Has something changed since Friday? I can't quite understand why something was working but now isn't and even when I try to create a new component it still doesn't work.

Any help appreciated?

We are aware of the problem - not a new issue but we have had a hard time pining down the root cause (initialization issue that I fixed in the next release). I have already opened a bug to track this issue and am actively working to backport the fix into Spring '08 asap.

Can you try editing and saving using the editor in Setup instead of the in page editor? Also it sounds like you used the quick fix to create the component - can you try using the "old fashioned" Setup ui instead as a potential workaround?
Hi Doug,

If I use the workaround, am I correct in thinking that I cannot change the custom controller code as well? The reason I use the other method is so I can see both the content and controller at the same time and see the changes once saved.

Many thanks.
No you just have to have 2 tabs open - one for editing the component's markup and the other for the controller source code. Anything you can do using the in page editor can always be accomplished using the old style Setup UI.