function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

<apex:outputPanel> repaints within Visualforce page via customer portal - privileges error

Hi all,
I am getting weird errors when I try and do a repaint of an area of my Visualforce page, in response to an actionFunction. The whole page initially displays ok, so I know that all the necessary apex properties are visible and accessible.
When I execute my actionFunction (via onchange of a picklist) I do a couple of things
- update the value of the field back to SFDC immediately
- redraw a section of the page
The code is:

<apex:actionFunction action="{!resetStatus}" name="redraw" rerender="commandbuttons" >

When I do this via my sys admin user it works fine. When I do via my customer portal user, I get an Insufficient Privileges error.
What's weird is that the update definitely works, as if I go back and check SFDC the updated value is there. This means the page refresh isn't working properly.

Things I have tried:
- debug, but this shows up no notion of the error, only that the action function posts and runs my code (without error)
- customer portal profile - all apex classes and vf pages have been granted, as well as field level security

I am not quite sure what else I can look at. The redraw of the section of page doesn't put anything additional on the page that is not already accessed when the page first loads (successfully), so I'm a little confused what might be causing this.

Anyone seen this before?

Could it be a permissions issue. Make sure are you having the problem on a visualforce page or a site?

I have ensured the profile has all VF pages and Apex classes.

The weird thing is, the page displays fine when I first go into it. Also in my debug logs, I can see execution going right from beginning to end, with no errors. So it would seem to be a system thing, that after execution it can't refresh the part of the screen that I'm requesting it to.


As a test, I will try doing a full page refresh (ie using PageReference), but this has all the qualities of a platform bug... 




Even I am getting the same error. Today morning rerender was working fine, but now i get the same error you got, 'Insufficient Privileges'. I started again from the scratch, cloned my profile, gave access to the objects, VF page, but again I am getting this error.


@StephenB : Did you get this resolved? What is the problem?


Any help on this is really appreciated. Thank you.


I wonder if this is related somehow to this thread:


I was trying to help the guy but haven't heard from him to see if he resolved his issue.   Best, Steve.


we've just been having what appears to have been a similar problem.


However, when I tried to add some debug statements to get more information on the problem, the problem seemed to disappear - I assume as a result of simply re-creating the class rather than due to the debug statements.


You may find doing the same thing solves your problem as well - although I'd still like to know more about what's causing it.