function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Inline Account Hierarchy



I modified the Inline Account Hierarchy app by labs for a custom object and it works fine. But for users who have 'Read-only' acces permissions on the custom object, they are unable to view the page.

Can anyone help me with this. It is an urgent request.


Thanks in advance.


What error are you seeing? If it's "Insufficient Privileges" you might check to be sure the users have page level security access on their profile(s).


The profile has access to the class and the visualforce page, but when the detail page is viewed the embedded VF displays the following:

Content cannot be displayed: Update access denied for  'Object name'.


The controller method does not perform any update.


Do these users get the same error when accessing the page directly?


Is there an action on the page that's trying to do something?


When access the page directly  using the url :'id'


Insufficient Privileges You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary.


Forgot to mention earlier, there is no action on the page. The VF page just calls the component.


Ok, so your user's profile has page level security access to the page and has read access to the object the standardController attribute value on the page is set to and the user can access the record directly, i.e. view the record with the ID you used in your test.


Are there any page includes or tempates in use (apex:include, apex:composotion)?


Try removing all the content of the page and calling it again, if you don't see the error then there's a reference to something in the page that's throwing the error. If you see it again then support needs to take a closer look unless someone else can step in with another idea without seeing your page and your organization's settings.


The user is able to view the record directly. The VF Page does not have any page includes or tempates in use (apex:include, apex:composotion). The VF page does not give any issues when the line 

<c:AssetHierarchyTree currentId="{!}" /> is removed.


but it gives the previous error with the component included.


Progress :)


What does the body of that component look like?


even if I remove the content of the VF Component, the VF Page displays the error.




And if you remove the controller of the component too?


Yes, even then too.


I tried to remove the VF component part altogether and move the component code in the VF page and it works fine but with the same code at component it does not work for user with 'read-only' permission.


Is this an issue with the VF Components?


HI All, I am facing the same issue,when a user with read only permission on Account tries to open a Account Page , the inline VF page Account Hierarchy dispalys the error Content cannot be displayed: Update access denied for Account .

After checking the VF page I do not find much of code  except this line in the VF page.

<c:AccountHierarchyTree currentId="{!}"/>


I would appreciate if any one among you have got the soluition for it and could help me.


We have the same problem with the stanard account  hirachy controller. I've tested and the user needs update on the accounts for it to work. Which is not acceptable by us.


I'm unable to find out why the Apex needs update access, but I'll get back if I find a solution.




Aaron EngelAaron Engel

We were able to make this error go away by removing the code from the component and placing the component code directly in the page.