+ Start a Discussion

Cannot enable Sites in Developer Edition

Hi community,


I've tried to enable Sites in my Developer account two or three times, but when I log into my developer account and go through Setup--> Develop the option Sites does not appear.


As I'm using Firefox, I noticed an error in the activation form by having a look to the errors console.


I also read other messages in the community talking about the same issue.


Can someone help me?


Thanks in advance.



Best Answer chosen by Admin (Salesforce Developers) 

We'll take a look at the form.


please email me (bcinarkaya@salesforce.com) your org id I'll enable sites for your De org. 

All Answers


Developer edition orgs created after the summer 09 release (6/15/09) are sites enabled by default.


If you have a developer edition created earlier, you can enable sites for your developer edition via http://developer.force.com/iwantsites page. 

The error occurs when submitting the form through the page you mention. Apparently no error happens, but having a look to the errors console you can see the error.

We'll take a look at the form.


please email me (bcinarkaya@salesforce.com) your org id I'll enable sites for your De org. 

This was selected as the best answer

I cannot get sites enabled. After searching for an hour, I found this page's instructions to use the "iwantsites" link. I visited that page and followed the instructions there. I did a hard refresh on the logged-in developer's homepage. I still get no "sites" link where the documentation says it should be - between s-controls and static resources - or anywhere else for that matter. I logged out and back in. No luck. I closed all my firefox's, logged out and then back in, no luck.


I need to advise a client regarding whether to build a completely custom site or use the Force.com sites ability.


Can you please tell me why it isn't enabled (I check and I do have all the necessary permissions), and it's a 'developer' account.




All developer edition orgs created after june 15th have sites enabled automatically (setup>appsetup>develop>sites)


if your developer edition org was created before june 15th hen you can enable it via iwantsites url (but seems like it's not working). If this is the case then please send me an email with your org id, I will enable it.


if your org is a 30 day trial org then sites is not (and won't be) enabled. Alternatively you can use force.com free platform edition.




Same problem. I have a dev org. Enabled force.com sites using the iwantsites link. Got a message saying that sites has got enabled. But when I login to my dev org, there is no "Sites" link under Develop in App Setup.


Can someone provide URL for the "Sites" link? At least I can try the URL and see if it works.



I am having the same issue.  I went through the sign up process but still don't see the "sites" option.  My account is definitely pre summer '09.





I have a DE as well that is pre 2009 and it looks like that like is dead.  Is it still possible to enable sites?  I finally have something to test that requires it.