function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Summer 08, soap and "SOAPAction HTTP header missing"

I have an app that has been working for quite some time. Since the upgrade to Summer08 everything is broken, I am getting: SOAPAction HTTP header missing It looks like this:

 <?xml version="1.0" encoding="utf-8"?>
    <soapenv:Envelope xmlns:soapenv="" xmlns:urn="">
        <urn:getUserInfo />

 Any help would be greatly appreciated.

My full response is:

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="">
<soapenv:Fault><faultcode>soapenv:Client</faultcode><faultstring>SOAPAction HTTP header missing</faultstring>

 It returns a status code of: 500 Internal Server Error which is strange to me.

I am posting to: which has worked for months.


Are you using Ajax toolkit?

If you are constructing the soap message by hand, you have
to set the SOAPAction HTTP header to empty string in the XHR.


I am using actually using coldfusion and it has worked very well. My coldfusion code below:

<cfhttp url="" method="POST" timeout="7200">
<cfhttpparam type="HEADER" name="Content-Type" value="text/xml; charset=utf-8">
<cfhttpparam type="HEADER" name="Accept" value="application/soap+xml, application/dime, multipart/related, text/*">
<cfhttpparam type="HEADER" name="User-Agent" value="Axis/1.1">
<cfhttpparam type="HEADER" name="Host" value="">
<cfhttpparam type="HEADER" name="Cache-Control" value="no-cache">
<cfhttpparam type="HEADER" name="Pragma" value="no-cache">
<cfhttpparam type="HEADER" name="Version" value="HTTP/1.0">
<cfhttpparam type="HEADER" name="SOAPAction" value="">
<cfhttpparam type="HEADER" name="Content-Length" value="#len(trim(salesforceSoap))#">
<cfhttpparam type="BODY" value="#trim(salesforceSoap)#">

Note: Content-Length and Body post the body and length.

The Header SOAPAction is blank.

It is very puzzling.

Try this:

 <cfhttpparam type="HEADER" name="SOAPAction" value="\"\"">


I tried that and get : Internal Server Error

What is the equivelant in a different language? PHP or Java?
In Java it will be:

 connection.setRequestProperty("SOAPAction", "\"\"");

On the wire it should write:

SOAPAction: ""

so essentially forcing a blank string?
Jill PlotkeJill Plotke
Was this ever figured out?  I am now having the exact same issue.  I can't figure out how to get ColdFusion to create an empty string without getting the following error: SOAPAction HTTP header missing