function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Unable to start HTML 5 application from Workbook



I have installed WAMP server on my laptop and deployed HTML5 application from for Mobile workbook.



App location: 



Modified Login.js:

var clientId    = 'valid client key';

var redirectUri = 'http://localhost/HTML5/oauthcallback.html';

var proxyUrl    = 'http://localhost/HTML5/proxy.php?mode=native'; 




After successful login I am not able to load the application. I am seeing spinning wheel "loading" .


Could someone help me. 





I am stuck in the same spot, however I am using a local apache server.  I have tried this on both a Windows/Apache setup and an iOS/Apache setup.  It looks like I am getting a response from the query to get albums, and the problem is occuring on the callback method back to the cloudtunes.js.  Any suggestions would be greatly appreciated.


double check the permissions on the proxy.php. They must be executable.


try to add at begining of proxy.php




I get the same thing.  Firebug indicates a problem with request to the proxy.  The GET url is http://localhost/Salesforce/MobileTutorial4/proxy.php?mode=native&_=1317748640885, which has a 500 response, and the the RequestHeaders are(OAuth removed and cookie truncated)



User-AgentMozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0
Acceptapplication/json, text/javascript, */*; q=0.01
Accept-Encodinggzip, deflate
Cookieoracle.uix=0^^GMT-4:00; _neig

Oliver WoolgarOliver Woolgar

For Windows Environments (Tested using  WAMP Server, and possibly apache)...


One thing to check is if the php server or web server  has the php_curl extension enabled.


If this is causing your problem within your one of the webserver log files you might see a log entry like this:


"Call to undefined function curl_init() in x:\???\???\proxy.php" where the path is our web application path.


To solve this problem open up the php.ini file and find a line similar to this.



If you find this line it may  be commented by using  preceeding ";".  This means php_curl is not enabled. (This is the default setting). If so uncomment save the php.ini file and then restart your web server. You may have solved your problem.


Hope this helps


The issue could be because of 2 things. 


1. Check if your wampserver (or other web server) install has php_curl enabled. To achieve this on wampserver left-click on the server's taskbar icon, choose PHP --> PHP Extensions - php_curl. This will enable the library for you

2. As we are accessing https from javascript curl will expect the security certificate authentication which is not present by default. Follow either of the fixes from the link here that would fix this. I followed the quick fix instructing curl not to do a ssl validation.


I hope this helps


I am facing the same issue. I have the HTML 5 app setup as described in the workbook. I followed the setps to uncomment php_curl and the SL certificate settings in the proxy.php. Still the App is unable to fetch any data. I see the sppininh wheel always.

Any help greatly appreciated.