function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Connector won't install sometimes

I've downloaded the sforce_connector PE and it works GREAT on most machines. On a few however, it won't install. I get a message from Microsoft/VisualBasic that says "Can't find Project or Library. Then it asks me for the sforce_connector password.
Has this happened to anyone else before? Does anyone know the password to the XLA? Maybe I can debug it on my own.
Neither "ttytytytyty" nor "sett" work

Many Thanks. Phil

It happens normally when your excel connector version mismatch with Office edition version.
Kidly confirm the office version like for example
Excel connector Version 6.16 must requires Office edition version 3.0.
You can varify your office edition version through your installed path (C:\Program Files\\OfficeToolkit)
you will find a folder with version name like 3.0
Please varify this and do the needful according to that.
Sunil prasad
That makes perfect sense.  That fixed the problem.  Thanks very much.
Ron HessRon Hess

Q: Does anyone know the password to the XLA?

A: this application is blessed with a password so that it can contain the required handshake to allow it to access the API even if your company has not purchased the API access, so, no we can't give out this password.  Normaly I build the EE version and then save it out to SourceForge, then go in and modify the same code to enable it to work on PE, then protect it with a random password, then delete the password.  So, any future changes to the PE version will be as a result of a fresh EE version and I don't keep the password, there is no need.


I have the same problem.

Where can I find office edition 3.0?

I only find 2.0 on

Ron HessRon Hess
Here is the latest Office toolkit, use this if you don't have the Outlook edition installed
they both contain the required com objects

Office Toolkit [AppExchange API 6.0]
The AppExchange Toolkit for Office: This Office plug-in makes it easy for developers to access the AppExchange API directly from within Microsoft Office products, simplifying the creation of new integrations and Office-based solutions.

View Online | Download HTML | Download PDF | Download CHM | MSI install
This is again the same thing, pe edition again require 3.0 versioned office edition. Kindly install it first.
Please refer my last message for details.
Sunil Prasad
Hello Everyone,
It took me a while to figure this out on my own.  There's some missing software that must be installed first.
The software that gives the 3.0 directory is the "Office Edition Excel add-in" from  Once that's installed, and you check that the "3.0" directory exists, then you can install the "Excel Connector". 
I don't understand how to get the 3.0 file required.  I have uninstalled and redownloaded office edition numerous times, but the file that is downloaded with it is 2.0.  How do I specifically fix this problem?  I had no problem installing it the first time and now it won't work at all on my new computer. 

I just keep getting the same errors everyone else is listing with the connector tool.

Ron HessRon Hess
here is the latest (3.0) toolkit install

taken from

Office Toolkit [Apex API 6.0]
The AppExchange Toolkit for Office: This Office plug-in makes it easy for developers to access the Apex API directly from within Microsoft Office products, simplifying the creation of new integrations and Office-based solutions.

The Office Toolkit is subject to the terms of's existing Support policies. will provide support for only the most current version of the Office Toolkit; including support for the most current version of the Toolkit's backing API. will post on its AppExchange Developer Network website, or any successor website, a notice of any new version of a Toolkit at least 30 days before that new version supersedes the prior version.

View Online | Download HTML | Download PDF | Download CHM | MSI install

I get the error described in  I have followed the faq's instructions, reinstalled Outlook Edition 2, reinstalled Office Ed. 3, Uninstalled/reinstalled Excel and even Office entirely.  I've recreated the inane temp file that Excel keeps looking for, I've moved the xla which allowed me to delete the entire addin from Excel, then moved the xla to a new spot and tried to add it in from there.  None of this gets me past the error message when trying to use the excel connector.

Can someone tell me what is wrong?
Yes, I am currently having this problem. IT has installed this 3 times now on my PC and it does not open. When I press the Alt F11 feature then try to open the connector it prompts me for a password...what is the password? How can I get connector to launch?
Foris AnctilForis Anctil

Would you send me the link to the download? "Excel connector" isn't on the AppExchange!


On my computer, it says it installed but when I click on "Table Query Wizard" to begin getting information from Salesforce it tells me the file could not be accessed.

I am running Excel 2007 and I could not find anything that explicity said Excel Connector worked with 2007 and/or Windows Vista.

Could this be the cause of my problem and if so, does anyone know if there is a work-around or even a new release planned?

If it is not the cause, does anyone have any suggestions?

Did you ever get this working? I can't see the menu in Office 2007 either.

Problem solved.  Upgrade to Office 2007 SP1.

Ron, can you please add to the install notes that the Excel Connector does not work with Office 2007 out of the box, but works perfectly with SP1.


We have a user here who has been using the Excel Connector but ever since he got a new computer, we cannot successfully install it on the new machine.

What happened was that before he migrated over to the new computer, he saved the xla file in a disc (his DVD rom was D: drive) so when he wanted to install the Excel Connector,

He ran the xla file from the disc in D drive.  Now whenever he wants to use the Excel Connector it tries to find the macro in D:.  We tried to completely uninstall the Office and Outlook edition and downloaded everything from the website (the Outlook Edition, Office Edition and the XLA file) and unchecked the AddIn in Excel and then adding it back by browsing to the XLA file in C:. But it doesn’t work.

It still tries to open the path D:_____ .xla whenever he tries to use the Connector.


Now the only way to run the Connector is to insert the disc in D: .  Is there a way to change the path?


Unistall it from the add in menu.

Close Excel

Open Excel

Go to the add in menu and browse for a new add in (in the new folder that you copied it to from the d: drive)

Close Excel

Open Excel

Should work.

When we tried uninstalling it and unchecking the AddIn in Excel, the ""  toolbar is still there when I selected "Add-Ins" on top. Is there a way to completely uninstall it?  I think that is what is preventing it from getting completely "forgetting" the AddIn even if we tried to install it at the new location.
Not sure, I seemed to have no problem changing directories when I was troubleshooting my install.
The other thing you could try is to uninstall the Office Toolkit (add remove programs under control panel).  That might break the Excel Connector and allow you to start over.
Thank you, I  will give it a try!

I am bit confused with connector for PE. Salesforce doesn't support Soap APIs for PE, but the connector uses Soap APIs. In that case, how does the PE Excel connector work?


I downloaded SForce office toolkit and Excel PE connector. I installed both of them. I am testing with DE, which works fine. But I am really concerned on suggesting to our PE customers.