+ Start a Discussion

truncating to 2 decimal places on pricebook entry

I'm using the Excel connector to update pricing in the PricebookEntry table. Our org has extended the available decimal places for pricing to 8 because we do fractional pricing. That means we can have prices that look like 0.125, 0.375, 0.32845678, and so on. If I enter these prices through the UI, no problem and they are correct. If I use the connector, it truncates them to 2 decimal places only.

I made sure the Excel column is formatted to show 8 places and the prices are correct in the cells. I update the cells and use Update Selected Cells, and the result in salesforce is 0.12, 0.37, 0.32.

It doesn't seem to matter if the column is formatted for numbers or currency.

[edit] I just tried the same update with the data loader and it worked fine, so the problem is definitely with the connector.

[edit2] I also tried using the connector with a custom currency field on the Product2 record and it successfully maintained the 3-decimal value. So the problem looks like it's specifically with the PricebookEntry UnitPrice and not other custom fields.


Message Edited by MarkL on 02-23-2007 09:31 AM

Message Edited by MarkL on 02-23-2007 09:54 AM


Thank you for sharing this.

I've noticed that the Excel Connector makes other assumptions about updating data as well:







This is an old thread, and maybe you all have figured out the answer to this by now, but I just thought I would post for the sake of someone looking in the future.  The issue with trying to load more than 2 decimal places into Product List Price is that Salesforce.com restricts that field to 2 decimal places.  If you want more decimal places, you can have them, but you have to request them explicitly through support.  If you search on decimal places in help and training, you will find the article.  


Hope that helps!