+ Start a Discussion

getSelected() preventing VF page from loading?

I have a custom list button that operates on a custom object.  The expected/intended behavior is that when the user checks the box next to a related list item and then clicks the custom button, my custom VF page will load and I will have access to the list of records that were selected by the user.  The was working find before the spring 14 update (but I have tried to roll back the page and controller extension to earlier versions, still having the same issue).

What is happening now is if I select the custom button without selecting any records my VF page loads fine.  If I select records from the related list before I click the custom button the page redirects, but never fully loads.  There is no new entry in developer console log and I am left with w blank screen
   I have also tried the example from the documentation here: 
http://www.salesforce.com/us/developer/docs/pages/Content/pages_quick_start_massupdate.htm?SearchType=Stem&Highlight=getSelected (http://www.salesforce.com/us/developer/docs/pages/Content/pages_quick_start_massupdate.htm?SearchType=Stem&Highlight=getSelected)

  And i get the same blank page result when I select records before clicking the custom button.

Any ideas?

acl5 - I just built a page similar to this requirement in Spring 14 and it works fine. Perhaps you can see a difference that might apply to you. Mass edit page works off the ContractLineItems related list under ServiceContract. No VF controller used. You'll note that the recordsetvar= is just to tell VF that a standardsetcontroller is being used, the actual table rows come from {!selected}; a method on the StandardSetController

<apex:page standardController="ContractLineItem" recordSetVar="cliList">

<!--  Related List mass edit VF page - invoked from List button on CLI RL  -->
<apex:form >
  <apex:pageBlock title="Contract Line Item Multirow Edit Form">
   <apex:pageBlockButtons location="top">
    <apex:commandButton id="saveBtn" action="{!Save}" value="Update Contract Line Items"/>
    <apex:commandButton id="cancelBtn" action="{!Cancel}" value="Cancel"/>
  <apex:pageBlock >
   <apex:pageBlockTable id="cliTable" value="{!selected}" var="cli">  <!--  {!selected} is ssc.getSelected() method result -->
    <apex:column value="{!cli.lineItemNumber}"/>   
    <apex:column id="sku" value="{!cli.SKU__c}"/>
    <apex:column id="skuQty" value="{!cli.SKU_Qty__c}"/>
    <apex:column id="skuUom" value="{!cli.SKU_UoM__c}"/>   
    <apex:column id="unitPrice" value="{!cli.unitPrice}"/>
    <apex:column id="totPrice" value="{!cli.totalPrice}"/>   
    <apex:column headerValue="Start Date">
       <apex:inputField id="startDate" value="{!cli.startDate}"/>
    <apex:column headerValue="End Date">
       <apex:inputField id="endDate" value="{!cli.EndDate}"/>
Thanks for your response crop1645v2!

I created a page using the VF mark-up you provided and added a list button and the select checkboxes to my contractline item object.  When I click the custom button the page redirects, but never loads.  I just get a blank screen like I was getting with my custom button and VF page.  I have tried in IE and Chrome and I'm getting the same result.  If I open up the developer tools I can see the hidden inputs with ids of the selected records.

Sounds like maybe the issue is unique to my org.  I guess I'll open a case and see what happens.
I opened a case with support, but it was closed immediately when it went to the development support team because custom development is no longer support for enterprise edtion customers.

The custom button and VF page work as expected in firefox, but still only loads a blank page in chrome and IE.  Any additional suggestions would be appreciated.