function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Community Visualforce Page Under Construction

When we try to get a visualforce page to be visible in our Community it says that the page is under construction and the worst part is that is references our other community.  Here is a Thread from an email regarding this.  I hope I can get some help on this.  Please and Thank you,

We need help with an error message that is coming up… And this is one of those weird ones again that we found.

We have a button called “Add New Items for Credit.” That when you select it should bring you to a visual force page. Now in the communicates environment when we select the button, it gives us an error message. Pay attention to the URL changes in the screen shots below. We need this fixed asap as this is a pretty big deal blocking roll out of communities.
User-added image

This is the error message… Notice the /ahold is missing now before the /apex.  Why??? Should not be like that. In addition, the error message is /APtea . That is a different community not yet published.

User-added image

This is what it should do and look like. Notice when we put the ahold in there as it should for the community, it works.

User-added image
Can you post the code you use in the button to recall the new page (VF or Apex)?
John HarrisonJohn Harrison
Hi ForceLogic, Here is the code on the button.... /apex/AddCreditItem?ParRecId={!Case.Id}  Thank you so much for trying to help, much appriciated. 
Hi John,
can you try to use this simple URL : AddCreditItem?ParRecId={!Case.Id} that is not /apex/ nor starting "/" ?
This is the page I get. [cid:image001.png@01CF8A1B.8E10A7C0]
The problem would be that this needs to be displayed as a URL... to set the flow in a visualforce with a URL (to transfer Current Page Identifications) and a finishlocation.  the page that we would get will be this... 
User-added image
Try using


instead of


This will add the part of the URL that is needed to redirect to the correct community
I tried this method and what it does is opens an iframe of the same window which is fine until i finish my flow which then results in the possibility of 2-∞ number of iframed windows.  I just want it to work the way it worked in the portal and internally.
Hi Moosecouture were you able to resolve it? I'm facing the same issue..
for anyone who comes across this ,  I was experiencing the same probelm and resolved the issue by removing the leading / character.
For the example given, use this in the button code: