function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
William LópezWilliam López 

Developer console no recording any logs on record edit

Developer Console Log on Record editHello I am trying to see the debug log when a update an opportunity so I can debug what a trigger does.

This is a developer edition ORG.

I have enabled the Debug Logs for my user:

User-added image

And I have my developer console open, but I dont get any debug line when I edit my Opportunity record.

User-added image

I don't know if I am doing something wrong here I need to anable something else.


Hi Bill,

Try this  -
1) Open developer console
2) Go to Debug -> Clear
3) Click on Log Panel (This will create the log panel.)
4) Now perform your edit operation and see if the logs are records.

I remember there were some issues regarding this earlier and then I performed above steps and all worked fine.

Vivek Patel.

Please like or mark this as best answer if this answers your question to help others find better answer and improve the quality of developer forum.
William LópezWilliam López
Thaks for the post Vivek_Patel,

But no luck, I even close and reopen the browers but the edit or creations do not appear.

Mason StaerkelMason Staerkel
I am having the same issue. I have logged a case with Salesforce but I wouldn't hold my breath on getting a good response on this issue from them (I lilke living :) ). I have tried everything from adding myself to the Debug Logs (my user record) in the setup menu, I have cleared out every rule. I have adjusted the general settings to be a detailed as possible, and as vague, I have tried multiple browsers, I have even tried enabling it for more than just my current logs. I am getting super pissed about this issue, and it is preventing any debugging (without a visualforce page that pops up java script because you cant use their system to debug) when developing. Also, I am not the only developer in my org with this issue. Anyone who can help, PLEASE DO. I am running out of ides for this.