function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Mike ArthurMike Arthur 

'URL No Longer Exists' Error when trying to log in to take challenge

This has worked fine for me in the past but today I'm working through Data Security modules and when I click 'Login to Take Chalenges' I get a pop up 'Login with Salesforce Account' button.  When I click that I get 'URL No Longer Exists'.  Anyone else getting same?
I have similar errors too.... When I click log refresh and says 'Trailhead requires you to login & connect with your Developer Edition org.'...then Click log in again, this shows again...never get me log in...
William MillsWilliam Mills
Me three!
Ron Lunan 1Ron Lunan 1
Brendon RitzBrendon Ritz
Same here. Something is clearly wrong with the Beta.
Roger PavelleRoger Pavelle
I've seen the same thing the last several days, but inconsistently.  Overall, though, the system seems VERY slow when processing anything on the trailhead, from showing completion stats to launching salesforce to verifying/scoring challenges.  If I knew how to notify them about these problems (outside of posting here), I would.
Graham Jack 8Graham Jack 8
Same here!
Graham Jack 8Graham Jack 8
Logging out and back in worked for me
Eric Kendi ShiraishiEric Kendi Shiraishi
Re-logging worked for me too.
michele Lashmichele Lash
Same here, can log-in once a day and can't re-login if I get kicked out.  Logging out or clearning cache doesn't work.
Mike ArthurMike Arthur
I figured out a workaround - when you get the 'URL no longer exists' message, scroll to the top right - your name is shown (assuming you were logged in to Trailhead).  Click your name and log out.  A login button is then shown on the left in the popup window.  Log in.  Return to Trailhead and refresh.  I was then able to Check Challenge.
Maybe just logging out and in again on the Trailhead page (as opposed to the popup) would work too as others suggest above.
Rammohan BandaRammohan Banda
Same here, I have observed this issue couple of times since last few days. However Logging out of the Account and then Relogin works for me.
KillerRamana KumarKillerRamana Kumar
Hi Mike,

Including visualforce pages in page layouts causes the page to not load and receives error: URL No Longer Exist. The URL that the error refers to is the servlet/servlet.integration trying to load the visualforce page.
Staring with Winter 13 release salesforce added a new feature in Setup -> Security Controls -> Session Setting ->
Enable clickjack protection for non-setup customer Visualforce pages.

Enabling this option will cause this error. To correct the situation simply disable this option.

Note: There may be other reasons for this error and this solution might not fix all those.
Andrea SchroederAndrea Schroeder
KillerRamana Kumar,

I have spent the last two days on a "URL does not exist" error in Campaigns related to an installed package (or so I thought). Salesforce Tier 3 support sent me to the package developer, and the package developer sent me back to Salesforce. Nobody was able to identify what was causing the issue, until I found this thread and realized we had "Clickjack protection" enabled, so I disabled it and everything works great now. 

Thank you for saving me future wasted time and helping resolve my issue via this old thread!!