function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Jessica RiffeJessica Riffe 

An internal server error has occurred while trying to deploy changeset to Production

An internal server error has occurred
An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience. 

Thank you again for your patience and assistance. And thanks for using! 

Error ID: 622001247-7550 (-697924050)


I receive this error message when trying to load the change set details page.

I tried to log a case with Salesforce.  Seems as though I was directed here and wasn't able to edit any of the case content to fill out the required fields... like Description.  Not sure how you guys could help me.  But if anyone has some insight, that'd be great.  Deployments were working fine yesterday.  I cloned my changeset to upload to production, that didn't work.  Create a brand new change set to upload to production and that didn't work.  So I went to the partial sandbox and created a new change set from there and uploaded it as well, and that also didn't work.  

Jess LopezJess Lopez
I'm having the same issue. Change sets worked fine until about two hours ago. I tried two of them, received internal server errors. I deleted both, combined them into one change set from my sandbox, redeployed, and received the same error. My error ID is: Error ID: 1967355794-45757 (-697924050). Of course I have something super pressing to deploy! 
Jessica RiffeJessica Riffe
I do feel slightly better knowing I am not alone, so hopefully it gets fixed soon.  :) 

Just as an FYI, I'm on NA16
Jack VolkovJack Volkov
Getting this same error trying to promote from a partial copy sandbox to a full copy sandbox.  Seems to be a temporary intermittent error.  Our org has a few change sets getting pushed into our full copy sandbox right now so it may have something to do with too much going on at once.
Casey Shockley 7Casey Shockley 7
I'm getting an internal server error when attempting to deploy a change set today, as well. Here's hoping it is just a temporary glitch - I have been getting the error for several hours now, though.
Jess LopezJess Lopez
Confirming that I'm having the same problem again today.
Jessica RiffeJessica Riffe
I've noticec that it happens pretty often when doing change sets in lightning.  Usually, the component gets added to the change set, however I usually have to go back to setup and navigate to the change set again and it is there.  It's annoying and I don't know why it is happening.  Probably just a growing pain with Lightning.
Adheena jacob 1Adheena jacob 1
Anybody got solution for this?
Kirsten De La HayeKirsten De La Haye
Adheena jacob 1,  I had the same issue today while there were a lot of outages on CS instances.  Once Trust showed the instances as back up and running normally, I was able to successly Clone and upload and redeploy the changessets (although the original uploaded changesets remain undeployable.  Hope this helps, if you are not already sorted!
Karla BedoyaKarla Bedoya
Does anyone have a solution for this? I just encountered this same error today.