+ Start a Discussion
Julien LussierJulien Lussier 

Data Error in Flow: Data Not Available


I've run into an error with the Flows in one of my orgs. Users were able to go through the flow with no issues, then out of nowhere everyone (including admins) suddenly started getting the following error when trying to start the flow process:

Data Not Available The data you were trying to access could not be found. It may be due to another user deleting the data or a system error. If you know the data is not deleted but cannot access it, please look at our support page.

I can confirm that the data DOES exist and has not been deleted, and that it can be accessed. There have been no changes made to the org between when it was working and when the error occured. The Flow is still working fine in our test environments.

Any help would be greatly appreciated.
Salesforce WizardSalesforce Wizard

Can you provide a bit more information? What is the data? What element is faulting? Is it a lookup? If so what's the lookup criteria.

If the flow is working fine in your Sandbox but it is causing an error in your production org then SOMETHING changed. It could be the data itself and how it's being looked up. It could be a permission issue. It could also be a system error or a GACK which will require you to submit a case to Salesforce to resolve.

Personally, I would rule out everything else and look very carefully at the data and the ways you're both looking up the data and using it. It is a odd error so you may have run into a strange system problem that will require you to submit a case.

Weird things I've done that have magically "Fixed" the problem.

Save as a new version of the flow & activate. Don't make changes. I know it's weird.
Remove the data and replace it (depends on what the data is)
Make sure I'm not using any hard ID in my Flow, because if you ever move instances this will break.
Julien LussierJulien Lussier
I've attached a screenshot below of the part of the flow that's bugging:


There are 2 lookups before the first screen, one that gets details from the opportunity, another one that gets details from a custom object.

Here's the thing that's weird though, I went back and checked and some users still go through the flow with no issues, but others can't, and this is off the same record. All users are running the same profile, there have been no changes (I looked at the audit trail).

I will attempt your trick to save and new and come back to see if it worked. Thanks.
Salesforce WizardSalesforce Wizard
Which lookup is giving you the data cannot be found error? 

Since the users have the same profile, check other permissions. Role/Ownership can also play a part in causing data not to be available. 

I had a similar weird issue until I realized all the users who had issues didn't have a role assigned to them (for some bizarre reason). 

If you have "login as user" enabled in your org, login as the users having the issue and manually go to the records in question. Make sure they're able to view the record and all the applicable fields. 
Admin User 4441Admin User 4441

I've follow the steps which you've mentioned post for Distrbuting Flow to comuunity user using VF page. I tried it on my Developer Edition and It works fine for me but when I trying it in my trail force org and beta org which are Enterprice orgs then it's showing me 'Data not Availible' Error. I also gave Vf page permission to community Login user but it's still showing me same error. Please help me out regarding this issue. Please Email me at iqrar.beyondvision@gmail.com