function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Veto SalesVeto Sales 

Drupal and SalesForce Suite Authorization Failure

I am trying to integrate SalesForce Suite with my Drupal site and I keep getting the following error:


I tried looking for a resolution or a reason WHY this is happneing and I have gotten nowhere.  See setup below.  Does it have to do with the endpoint URL??  Any help with this would be greatly appreciated.


Drupal Error

Martijn SchwarzerMartijn Schwarzer
Hi Veto,

In your connected app settings, you've defined a callback url. The redirect_uri url parameter must match this callback url. 

Which url parameter is used can be retrieved from the page where you get the error message (check the url).

The redirect_uri is sent by Drupal in your case. I don't know Drupal, so I cannot tell you which url is sent to salesforce or how to configure this.

My best guess to solve this is to copy the redirect_uri (retrieved from the error message url) and paste that in the callback url setting of your connected app. Otherwise you can check Drupal to see where to configure the redirect_uri parameter.

Hope this helps!

Best regards,
Martijn Schwärzer

Ps. If my answer helps you to solve your problem please mark it as best answer. It will help other to find best answer.
Veto SalesVeto Sales
Hi Martijn,
Thank you for your reply!  In the instructions I followed here: (, it says to place this callback URL:  https:///salesforce/oauth_callback in the App settings and I also placed this in the Drupal site and I get a server not found error. 

I also tried these variations and had no luck:

I guess my question is, which is the correct one to use for both systems??

Martijn SchwarzerMartijn Schwarzer
Hi Lisa,

I noticed an extra "/" in your url: https:///salesforce/oauth_callback

Is that a typo in this thread or did you actually have a typo in Salesforce? That may well be the issue...

Hope this helps!