function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Amanda WurtzAmanda Wurtz 

Can't log into developer edition

Hi, I have been working on the Admin Beginning trail today and this afternoon I haven't been able to lauch the developer edition. It keeps taking me to a page where it says I have log into Salesforce first but I'm already logged in. I go ahead and log in and then I click again to launch and enter my developer login and it doesn't accept it or give any errors except that I need to log into Salesforce first. I'm a bit confused. I tried a different browser (tried both Chrome and IE) and tried clearing the browser cache. Thanks in advance for your help! 


I did run into similar issue when I was working on trialheads. I don't know the exact reason for this, but this should help. When you have clicked on "Log into Salesforce", then I guess you were able to log into your developer edition. Now without closing the window work on the test case given by Salesforce. This was you don't have to click on "Launch Developer Edition". After working on the task, just click on "Check Challenge".

Thank you.

SandhyaSandhya (Salesforce Developers) 
Hi Amanda,

I suggest you follow the below steps when working with trailhead.

1.Login to trailhead

2.once you are in the challenge it will ask you connect your developer edition.

login with your credentials.

User-added image

3.launch your developer edition( again login with your credential to enter into platform)

User-added image

4.After you finish the challenge, you need to check challenge.

User-added image

Please accept my solution as Best Answer if my reply was helpful. It will make it available for other as the proper solution. If you felt I went above and beyond, you can give me kudos.
Thanks and Regards

Andrew RasmussenAndrew Rasmussen

I got stuck in this same issue. Here's how I solved it!

On the login page, rather than clicking on the development account that was already logged in, I clicked on "Log In With A Different Username". I then entered my username (email) and password for my development account (even though it was already logged in!). After logging in, it worked! So weird.

Dustin FinkleDustin Finkle
I'm having the same issue. Any help would be greatly appreciated! None of the items above worked for me.
Yaron TigerYaron Tiger
Hi, can you please reset my passward, my user name is
Pat HarrisPat Harris
This happened to me today. what @Andrew Rasmussen said worked for me.
Vigneshwaran GopalVigneshwaran Gopal
I just tired in an Incognito browser window and it worked.

Then in my normal browser window, I just cleared all the browser data including cache and other cookies, etc. It worked!

Seems like a one-time issue with session id after enabling the My Domain.

Hit 'Like', if this works.