function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Create Global Quick Actions | Hands-on Challenge issue

My issue may be tied to creating the Global Action and the appearance of a recod type field.
When I take the challenge, I get the following error:
"Challenge Not yet complete... here's what's wrong: 
Could not find an Opportunity Quick Action with the Label 'New Offer' and the action type of 'Create a Record'."

User-added image

It would seem I did everything right, but I also see a Record Type field with 3 options, Products, Serivces, or Master. I set it to 'Master'. 
User-added image
I then set the Predefined Field value to Stage: 'Qualification'
User-added image
User-added image

Then set the Publisher layout.
User-added image

Am I missing something?

Thanks to anyone who can help. It would seemt the system can't find my Quick Action.
Best Answer chosen by djkentuckyham
Suraj TripathiSuraj Tripathi
Hi  djkentuckyham,
Do one thing, First delete the "New Offer" Global Action and create again Global Action and follow all the step of the trailhead.


All Answers

Suraj TripathiSuraj Tripathi
Hi  djkentuckyham,
Do one thing, First delete the "New Offer" Global Action and create again Global Action and follow all the step of the trailhead.

This was selected as the best answer
I already tried that. Nothing. Aame error. Can't find my quick action.
Suraj TripathiSuraj Tripathi
Create in Playground 2 and then check challenge,m maybe it will work.
Thanks, that did it. My 'Developer Edition' account gets stuck on this challenge. That was what I was validating against. I employed my 'Trailhead Playground' and it worked. Cheers!
Suraj TripathiSuraj Tripathi
Hi djkentuckyham,
I am glad it worked for you if you find my answer helpful please mark it as the best answer so that it can help others as well.

Vinit JoganiVinit Jogani
I had the same problem on Develper Edition, i had record types created for opportunity. In place of Master, I selected the first record type in the list and it worked. I did not use Trailhead Playgroud for this.
Francesco MartireFrancesco Martire
Vinit's solution also works with Trailhead Playground.
Issac ChuaIssac Chua
Vinit's solution is correct, mine here was "Happy" as the first pick from picklist.
Malke SianMalke Sian
I am having the same issu as djkentuckyham. I tried opening in another playground and error is still there. When I created the action the Label automatically changed to "Create New Opportunity" from New Offer. See screenshot below. Please help. User-added image
Philip BurnsPhilip Burns
Thanks,  another one where Vinit's solution worked.
Supriya DiwarathnakumarSupriya Diwarathnakumar
Thanks Vinit, first picklist solution is worked with me too. 
User-added image
Me too, in place of Master, I selected "Opportunity Type" in Record Type list and it worked. I use Trailhead Playgroud.
James Pineda 7James Pineda 7
Same problem.  Per Suraj, I opened a new playground, created global action, added to layout, and passed the challenge.  Thanks!
Sarah VacchianoSarah Vacchiano
Must be in Classic
Sarah VacchianoSarah Vacchiano
Had to change Trailhead Playground, too.
Devendra PatelDevendra Patel
I also had the same problems, so i have selected first opportunity record type insted of master 
Mohamed Javith KMohamed Javith K
Choose the first opportunity record type instead of Master record type  
Prashant Gupta 109Prashant Gupta 109
Hi All
I'm new to Salesforce Ecosystem, and currently doing trailheads, I came across this assignment in which I need to create one global action for creating New Offer for target opportunity
First I have tried it in Developer Edition in which one field is visible for creating Global Action : New Offer 
option is coming : Record Type & when I opens another trailhead playground this option is not coming, Can you please help me why it's coming in Developer Edition and not coming in other Trailhead Playground ?
Faris Apuk 5Faris Apuk 5


I had the same problem. You have to put Label as "New Offer" and Name as "NewOffer". For the Standard Label Type put --None-- because if you put New [Record] it will automatically take out Label. Please check the picture!

User-added image

Alexandru Catalin Cristea 1Alexandru Catalin Cristea 1
I got the same issue using Master as Record Type. It seems the solution for me was to use Products. So I just edited the Global Action and updated Record Type.
Using Service Record Type would not work as the Qualification stage is not available for it.
I hope this helped.
Akash Jain 13Akash Jain 13
For me, there was no Record Type field. But when I created a new playground and followed the same steps, it worked!
Echezona AgubataEchezona Agubata
Ok, you did well. Two things can cause this:
1. if did not had a type in the name of the global action created. Please ensure the Label is 'New Offer' and the automatically populated Name is 'New_Offer'
2. if you did not select the default/active record type for the object (you can go to object manager, search for the object in question: opportunity, then select Record Type. Check the list of record types. default is usually master. However, if you have another custom record type, it would show if its the defult)
Adrian Tanase 10Adrian Tanase 10
Hello , 
If you changed playground and you have the same error try to change Record Type on another one from picklist. 
Record Type