+ Start a Discussion
Duncan McGovernDuncan McGovern 

Help with communities permissions for package fields

I would like to use a visual workflow to walk community users through making a payment with the Blackthorn Payments app and have encountered an error I can't figure out. I am pretty new to the developer side of things but have been able to work through a lot of these errors before although this one has me stumped.

So my community user does not have access to the field "Transaction" somewhere, but I can't figure out where that field is hiding. Do any of the error codes that follow tell me anything? I've used my browser search to go through everything on the package manager page to see if I can find that field ("Transaction", nothing else) without success. Maybe there's something else going on with the "AfterInsert" that references a different "Transaction" field that I can't find... I'm not sure. The flow is able to create a "Payment Method" object earlier, but fails on the Transaction object. I tried giving the community profile Modify All permissions on Transactions just to see if that would fix things, but no luck. So that Transaction field must be hiding somewhere else.

Thanks very much for any help!

Here is the error:

Error Occurred: This error occurred when the flow tried to create records: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY: bt_stripe.Trans_Gen: execution of AfterInsert caused by: bt_stripe.SObjectService.SObjectAccessException: Payment360: You can't access this field: Transaction Error Code Class.bt_stripe.SObjectService.checkFLS: line 215, column 1 Class.bt_stripe.SObjectService: line 169, column 1 Class.bt_stripe.Transaction_PopulatePMEmail: line 39, column 1 Class.bt_stripe.SObjectTrigger.handle: line 108, column 1 Class.bt_stripe.TriggerHandler.manage: line 257, column 1 Trigger.bt_stripe.Trans_Gen: line 7, column 1. For details, see API Exceptions.