+ Start a Discussion
Richa NayakRicha Nayak 

How to solve this issue? "Challenge Not yet complete... here's what's wrong: You haven't installed the DreamHouse app package."

Challenge Not yet complete... here's what's wrong: 
You haven't installed the DreamHouse app package.
Zachary WaltonZachary Walton
Can you please give more info about what Trailhead Challenge you are talking about? What have you tired?
Siddharth SethSiddharth Seth
Hi Richa Nayak

Please check before checking the challenge that you have installed the package in correct playground  and worked on that same playground.

Best Regards,
Siddharth S.
AppPerfect Corp.
Raymond Mar 6Raymond Mar 6
I can't complete the Hands-on Challenge.  I installed one Trailhead Playground.  I tried uninstalling DreamHouse app to reinstall.  Package doesn't uninstall.  The module is Trailhead Playground Management.  Can someone uninstall the package or reset the Hands-on Challenge?

Screenshot Error message Haven't Installed DreamHouse App

Raymond - I have the same issue as you, it seems. I get the error that the challenge isn't complete because the DreamHouse app isn't installed. However, it is showing as installed...so I try to uninstall it and get an error that something is being used in the profile and therefore I can't uninstall...anyone else have any recommendations?
Raymond Mar 6Raymond Mar 6
April, I successfully completed the Hands-on Challenge.  Unfortunatley, I can't post the step-by-step process because I forgot what I did.  I vaguely remember renaming a module or renaming something else.  I think I renamed "My Trailhead Playground 1" to another name.  Then I installed the DreamHouse app which was successful.
I figured out what to do. I ended up having to create a new Playground. The original one for some reason wasn't working properly. Once I went with the new one, all is well. Thanks!
Sean CarneySean Carney
I have created multiple playgrounds but it still fails for me every time.
Sang Tran 9Sang Tran 9
Package ID: 04tB0000000OE9wIAG -> DreamHouseLWC
This challenge needs a package name "DreamHouse" not DreamHouseLWC. Change Package ID to 04tB00000009UeX
Simran AgarwalSimran Agarwal
Sang- Thanks. Changing the package id worked for me.
Sean CarneySean Carney
How do you change the package id. I would like to try that. I do for sure see that Dreamhouse is installed. This seems to indicate to me that Dreamhouse was installed
Sean CarneySean Carney
It is installed under the url: https://curious-raccoon-prdi7j-dev-ed.lightning.force.com/lightning/page/home

That is the url I am taken too when I click on the launch button for my playground where I installed Dreamhouse. 
Sang Tran 9Sang Tran 9
Sean - Check package's name in installed package, if it is DreamHouseLWC, uninstall it and install new package with Playground Starter App, this time use above package ID. 
Sean CarneySean Carney
That was the right advice. Thank you so much. I followed your instructions and am now the owner of a bright shiny badge.  :-) 
That was driving me nuts. I hate when things are not working. Especially when I am supposed to be learning. The good news is that I had to learn a lot more about Salesforce because of all that. :-)