function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Brian KesslerBrian Kessler 

Cannot link Alexa Private Skill to SFDC Org

I'm currently trying to Create a Connected App and Link to Alexa.

When I click "Link Account", I get a new tab which displayes an "OAuth Error":
We can't authorize you because of an OAuth error. For more information, contact your Salesforce administrator.

OAUTH_APPROVAL_ERROR_GENERIC : An unexpected error has occured during authentication. Please try again.

The result page URL offers a little more information:

These are the Selected OAuth Scopes for the Alexa Skill Connected App in SFDC:
Access and manage your data (api)
Provide access to your data via the Web (web)

Any ideas what is wrong or how to fix it?

Chris Scheppler 4Chris Scheppler 4
Brian, you need to ensure these scopes are selected in your connected app in Salesforce:
User-added image
Brian KesslerBrian Kessler
Thanks for your response.
Unfotunately, I already tried that (about a week ago),but it didn't fix it.

I think the problem may have something to do with Amazon refusing to leave me in, but rather forwarding me into all the time. 

(I am not sure why this is.  I am actually n Hungary, which may be close to German, but the number of German speakers isn't so much higher than the number of English speakers, Hungarian is a completely different language, and the import laws make shopping any Amazon site equally frustrating.)

1. I couldn't find any way to tell Amazon/Alexa that I am not in Germany and do not speak German and have no desire to interact with the .de domain.
2. I couldn't figure out any way to set up testing of Amazon/Alexa for users who have logged into the .de domain.

There were some indications that the required feature of Alexa is still in beta and hasn't been rolled out globally, but if you have any further suggestions how to make this work, I'm all ears.


Chaithanya peethalaChaithanya peethala
Hi Brian Kessler

I also got the same issue earlier when I used my dev environment and later I tried with trailhead playground it worked for me
Please try with trailhead playground and let me know if still error persists