function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Visualforce Page Links Fail When Critical Update Activated

There is a new critical update called Remove Instance Names From URLs for Visualforce, Community Builder, Studio, and Content Files.


This changes links for visualforce pages.  <domain name> replaces <domain name>.<instancename>

For whatever reason, this does not work with Visualforce tabs or with buttons that link to visualforce pages.

With the critical update deactivated, the link for visualforce tab is https://<domain name>.<instancename>

When the critical update is activated, the link for the visualforce tab is https://<domain name>

The problem is that clicking the "activated" link yields this:
This site can’t be reached
<domain name>’s server IP address could not be found.

In my case, it was a really big problem because the visualforce tab was the default home page. So activating the Critical Update essentially locked all of my users out of 

This also fails with a simple button link to a visual force page.

If you assign a url to a button or type the link in - /apex/TimeEntryCalendar for instance, it works fine when the update is deactivated.

But activate the update, and it fails on just the simple link.

Problem exists in both Classic and Lightning.

Evan WilleyEvan Willey
Did you make sure to include the "--c" at the end of the domain name?
E.g. ""
Replying to Evan Wlley . . .

This is the message I get:
This site can’t be reached’s server IP address could not be found.
Try running Connectivity Diagnostics.

So yes, the --c is in the link. But the page is not being served up.
Evan WilleyEvan Willey
Your visualforce tabs, they're actual "Visualforce Tab" tabs right? Not just "Web Tab" tabs that happen to link to your visualforce page?
Also, in your "My Domain" settings, what's your redirect policy? If it's set to "Not redirected (Recommended)", try changing it to one of the redirect options.
The tabs are legitimate Visualforce tabs, created by linking a Visualforce page to a tab. Also, a button to a url - /apex/<visualforcepage> - does not work.

I try the various options on the redirect. Still no difference.

I tried pinging the new link for the visualforce page - Still get server not found.

I tried to reproduce this in another org, but apparently the critical update only applies to orgs that have specified a "My Domain." 
Mark BatcheckMark Batcheck
Thank you for your post, Claiborne! After about 5 hours of trying to figure this out, I found your post and just simply deactivated that "Critical Update" and everything's back to working again. Ugh
Mohammed Al-SaidMohammed Al-Said
this wired behavior happens to me when I switch back and forth between classic and lightning with and without the new update the app stopped working for some reason I solve this problem by clearing the browser cache every time i Activate or deactivate the new update in lightning it seems that SF has a bug in this area 
I have also faced similar issue after enabling the update. Please follow below steps and see if it works:

1. Enable the critical update
2. Logout from Salesforce
3. Clear browser cookies
4. Close browser
5. Login again and access any custom VF Page

It worked for me.
Big EarsBig Ears
We're having a similar problem, but a different error message: "Content cannot be displayed: org.apache.commons.httpclient.RedirectException: Maximum redirects (100) exceeded"

I've cleared my cache and logged out and back in but are still seeing the issue. Have you had any luck?
Hi Big Ears, I have the same problem with you. And not like sfdcdev mentioned, after cliear cache cookie and all of them, wait for more than one weeks, the problem still occur.
My issues is described here: