function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Bobby WhiteBobby White 

Learn About Object Design-Time Limits - Check Challenge fails even though solution is working

Challenge Not yet complete... here's what's wrong:  Changing the owner of the Account record failed to update the 'Account_Owner_Name_Process__c' field for the Case object . Make sure that the process is correct and that it is activated.

I've implemented the Process Builder on Account to update the Case.Account_Owner_Name_Process__c field if Account.OwnerId changes.
The name is correct 'Update Case Account Owner' ( API Name: Update_Case_Account_Owner) and it's active.

My process builder:
Process Builder is Active

Object - Account - fire on changes

Owner is Changed Entry Criteria

Update Related Cases immediate Action
Michael McGeehanMichael McGeehan
I'm having a similar problem with the lab "Automate Basic Business Processes with Process Builder".  In that lab, the address fields in the Contact object should be modified if the address fields in the Account object change. In the Update Records Action, I used:

Master Record ID Equals Field Reference [Account].ID

but that didn't work.

I took note the comments in the article below but it still doesn't work.

Hoping to get ideas from any responses to your issue.
Michael McGeehanMichael McGeehan
Interesting. I got it to work but used the wrong fields in Process Builder. I then deleted the Process Builder instance and created a new one. The new one didn't work because it was like the original was still active. I deleted the new Process Builder instance and the Contact object is still updated as if the Process Builder instance still exists. It's a ghost process! 
Michael McGeehanMichael McGeehan
So as it turns out, setting the Contact object's Master Record ID Equal to Field Reference [Account].ID does not resolve accorately. At this point, I don't know how to join the Contact Object to the Account Object.

Update Records Process in Process Builder does not recognize a condition linking Contacts to Accounts
Bobby WhiteBobby White
I solved it myself by getting rid of the entry criteria on the Process builder and having it always fire.   I think this is sloppy and brute force, but it allows it to pass the challenge.
Michael McGeehanMichael McGeehan
I just did the same Bobby. In the real world, the matching condition can't be disregarded. I'm wondering if we found a bug. Thanks.
Still issue not resolved.......any resolution?
Francis CrumpFrancis Crump
Nothing worked for me, wasted about 4 hours on this now.
Heather CreelHeather Creel
wow that is frustrating, removing the 'is changed' criteria allowed me to pass it as well but...that isn't right and this should've been an easy one but took my longer to try and trick the system into letting it pass. 
michael skea 5michael skea 5
still not working. the process works in practice but still won't pass the challenge
Ayan Pramanik 17Ayan Pramanik 17
Update your own user name with firstname as 'Person2' and lastname as 'Test'.
The test code assertion is schecking against this name
Rahul Kumar 652Rahul Kumar 652
For completing the given challenge you have to follow the steps :
Please create a new text field, with length 80, on the Case object: Account Owner Name (Process)
Verify that the field API NAME is Account_Owner_Name_Process__c and delete the field with name : Account Owner Name (Formula) if it exists.
Setup --> Process Builder 
Create a new process builder with name : Update Case Account Owner
Select value from "The process starts when" picklist  : a record changes
Object : Case
Start the process : only when the record is created 
Criteria Name : Account record changes 
Criteria for Executing Actions : No criteria—just execute the actions!
Immediate Action:
                      Action Type : Update Records
                      Action Name : Update the account owner
                      Record : [Case]
                      Criteria for Updating Records : No criteria—just update the records!
                       Field : Account Owner Name (Process)
                       Type : Formula
                       Value : [Case].Account.Owner.LastName & " " & [Case].Account.Owner.FirstName 
The FirstName and LastName are in the order mention above.
Save the Process and don't forget to Activate it.
The same procedure helps for me , for completing the challenge .
Please mark it as best answer if it helps you.
Thanks all :)
Eddie Caballero 1Eddie Caballero 1
This workaround resolved the issue for me! Thanks @Rahul. In my case my issue was the formula. I kept using [Account] and not [Case] on the formula. The error was misleading for me as the formula existed in the Case > Account Owner Name (Formula) even before I deleted it but makes sense on why we would use [Case} to reference the Case object and not Account. 
Christopher Adams 43Christopher Adams 43
Did this today and you have to chose "No criteria - just execute the trigger" 
George Azevedo FilhoGeorge Azevedo Filho
Doing this challenge in a new playground worked for me.