function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
yash mehta 12yash mehta 12 

Challenge Not yet complete... here's what's wrong: Could not find a custom field on the Account object with the API Name 'Support_Plan_Start_Date__c'.

Challenge Not yet complete... here's what's wrong: 
Could not find a custom field on the Account object with the API Name 'Support_Plan_Start_Date__c'.User-added image
click on the set 'field level security' button and make sure this field visable to 'System Administrator' (your user profile), and if you still getting same issue logout from trailhead account, clear browser cache and recheck again

Let us know if it helps you
yash mehta 12yash mehta 12
This is trailhead task I have done as per trailhead only but see showing same errorUser-added image
SandhyaSandhya (Salesforce Developers) 

Make sure that you have connected to the same org where you have created the custom fields.Click on "Launch" to check the org connected against the challenge.

Please mark it as solved if my reply was helpful. It will make it available for other as the proper solution.
Best Regards
Marie LefortMarie Lefort

If you do not have the answer yet, here's what you can try:

Trailhead mentions the fact that you should deactivate a validation rule for this challenge.
Here, it is the fact that the field "Support Plan..." should not be required to create records.

However, as I see in your screenshot, it is unchecked. As soon as I unchecked it, y challenge was complete...
Ravi R 9Ravi R 9
I was able to reproduce the Error and got the solution. Hope this helps if anyone get the same error.
Trail Mix : Prepare for Your Salesforce Administrator Credential

Module : Customize an Org to Support a New Business Unit 
Sub Module : Modify Your data Model

Error : 
User-added image
Soultion : 
User-added image
What you need to do :
Select both headers (put a check mark) "Visible" & "Read-only".
Then deselect the "Custom : Support Profile"  & "System Administrator" under "Read-only" Header.

User-added image
Hope this helps.

savita arekarsavita arekar
None of the solutions is working for me. I tried all the possible resolutions, but no luck and unable to complete the challenge.