+ Start a Discussion
Ramu TungalaRamu Tungala 

Something Went Wrong while executing the Extract_OpportunityLineItem

Hello All, I am trying to create a dataset in the trail "Build and Administer Analytics" >> "Analytics Data Integration Basics" >> "Extract Salesforce Data into Analytics".

I am getting this weird error continuously. Something Went Wrong while executing the Extract_OpportunityLineItem.

Not sure what is happening s this seems to be pretty straight forward task.

This is the default Salesforce dataflow.
Organization:Cognizant Technology Solutions (00D6A000001kgyl)
Reason for Failure:Something went wrong while executing the Extract_OpportunityLineItem node: Error during local fetch: Replicated dataset was not found. Verify that the replication dataflow for object 'OpportunityLineItem' completed successfully. (02K6A00000011KUUAY_03C6A000001E9V6UAK)
Start TimeEnd TimeDuration
03-01-2018 21:12:51 GMT03-01-2018 21:12:54 GMT3 seconds

Node NameNode TypeDurationStatusInput
Extract_AccountsfdcDigestLess than 1 secondsuccess1,00101,0010
Extract_OpportunitysfdcDigestLess than 1 secondsuccess70607060
Extract_OpportunityLineItemsfdcDigestLess than 1 seconderror0000
optimize-register_Opportunities with Accounts and UsersoptimizerN/Aaborted0000
optimize-register_Opportunities with Accounts and Users_0optimizerN/Aaborted0000
optimize-register_Opportunities with Accounts and Users_1optimizerN/Aaborted0000
register_Opportunities with Accounts and UserssfdcRegisterN/Aaborted0000
register_Opportunities with Accounts and Users_0sfdcRegisterN/Aaborted0000
register_Opportunities with Accounts and Users_1sfdcRegisterN/Aaborted0000
Dave Austin 4Dave Austin 4

Having the same problem today with the "Add More Data to Analytics Dashboards​" module


User-added image

Claire ErskineClaire Erskine
I am having same error as Ramu trying to create a dataset.
David Tropp HagDavid Tropp Hag
Same issue here - trying to create "Opportunities with Accounts and Users" but get the following error:
User-added image
Jon Oatham 10Jon Oatham 10
Hi everyone. It looks like replication got turned on for the DE orgs you're using, and this is what's causing the dataflow error. Replication is not needed for this Trailhead module, so the easiest workaround is to turn it off and rerun the dataflow.

To turn replication off in your DE org:
  1. From the data manager or Analytics Studio, click the gear icon at the top and select Setup.
  2. In the Quick Find box at the top of Setup, enter analytics.
  3. In the results, click Settings.
  4. Clear the checkbox for Enable Replication and click Save.
To rerun the dataflow:
  1. To return to Analytics Studio, in the top-left corner click Trailhead Data Manager and select Analytics Studio.
  2. To return to the data manager, click the gear icon at the top and select Data Manager.
  3. In the data manager, click the Dataflows & Recipes tab.
  4. To the right of the Default Salesforce Dataflow, click the action menu button and select Start.
I'm looking into getting replication switched off in the DE org provided for this module.
Mateusz O WolfMateusz O Wolf
Thanks Jon, this resolved the issue for me
Jon Oatham 10Jon Oatham 10
Update: New DE orgs for this Trailhead module now have replication off, so you won't hit this issue if you sign up for a new org.
Lr XieLr Xie
Hi, I'm getting another error as below for the same course, could someone help?

Something went wrong while executing the digest node: Only the dataflow owner or users with the View All Data permission can download the log. (02K3i0000005doQEAQ_03C3i0000002YFiEAM)
雅人 松村雅人 松村
I could solve the same issue by following this procedure.

Angela Davis 36Angela Davis 36
Thanks @雅人 松村, very similar but not exactly the same to your suggestion. I had the objects but had to Connect to for both Opportunities and Users when I encountered the following errors:

Error 1: Something went wrong while executing the Extract_Opportunity node: Error during local fetch: Replicated dataset was not found. Verify that the replication dataflow for object 'Opportunity' completed successfully. (02K4R000000goWJUAY_03C4R000000yYKyUAM)

Error 2: Something went wrong while executing the Extract_User node: Error during local fetch: Replicated dataset was not found. Verify that the replication dataflow for object 'User' completed successfully. (02K4R000000goWJUAY_03C4R000000yYL8UAM)

Error encountered
Andres Garcia 30Andres Garcia 30
I resolved the issue, pretty easy, aparently it is a problem of Data Sync... just go to Connect in Data Manager, and Run Data Sync for Accounts, Opportunities and Users. after the process is done (go to Monitor and wait until the sync is done), re-run the Default Salesforce Dataflow,,,
Michael Friedman 16Michael Friedman 16
Andres Garcia's solution worked perfectly for me.
Kamlesh KoratKamlesh Korat
I followed Andres Gracia's instructions and it worked great as instructed.  thank you for sharing.
Aditya Verma 39Aditya Verma 39
@Andres Thanks for sharing the solution .
Mike Davis 57Mike Davis 57
I had the same error and Adres Garcia's solution solved it.