function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Kristina Rose LytesonKristina Rose Lyteson 

Error with running trailhead dataflow - Extract Salesforce Data into Analytics 

I've tried creating my dataset 4x for Extract Salesforce Data into Analytics trailhead and each time I"m getting a failed when I try and run it with the following message "Something went wrong while executing the Extract_OpportunityLineItem node: Error during local fetch: Replicated dataset was not found. Verify that the replication dataflow for object 'OpportunityLineItem' completed successfully. (02K6A000000kveMUAQ_03C6A000001Q8g3UAC)"

Would appreciate help fixing this issue.
NagendraNagendra (Salesforce Developers) 
Hi Kristina,

It looks like replication got turned on for the DE org's you're using, and this is what's causing the data flow error. Replication is not needed for this Trailhead module, so the easiest workaround is to turn it off and rerun the data flow.

To turn replication off in your DE org:
  • From the data manager or Analytics Studio, click the gear icon at the top and select Setup.
  • In the Quick Find box at the top of Setup, enter analytics.
  • In the results, click Settings.
  • Clear the checkbox for Enable Replication and click Save.
To rerun the data flow:
  • To return to Analytics Studio, in the top-left corner click Trailhead Data Manager and select Analytics Studio.
  • To return to the data manager, click the gear icon at the top and select Data Manager.
  • In the data manager, click the Dataflows & Recipes tab.
  • To the right of the Default Salesforce Dataflow, click the action menu button and select Start.
I'm looking into getting replication switched off in the DE org provided for this module.

Hope this helps.

Kindly mark this as solved if the information was helpful.

William BainWilliam Bain
I am having the same problem but there is no Enable Replicaiton option in my Settings list. See screenshot below:
Any help would be appreciated.
screenshot of analytics setting options
Thomas The Tank EngineThomas The Tank Engine
Same as Brian. No option to deselect replication. Is there another way to do this?
Randi Thompson 22Randi Thompson 22
I deselected the Enable Data Sync and Connections setting and was able to run my dataflow successfully, without that pesky replication error.