function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Riyas MRiyas M 

Permission sets not working to enable Email-Based Identity Verification Option instead of SMS

Hi All,
Someone help me to fix my issue, I spend many hours to figure out enabling "Email-Based Identity Verification Option" but nothing helped.

  1. Cannot change standard user profile called "System Administrator" so I cloned it but cannot assign my user to the newly cloned profile. I am using developer edition, is that cause?
  2. Created new "Permission Set" by going Setup|Users|Permission sets and checked "Email-Based Identity Verification Option" under System Permissions. and Assigned my user
Nothing helped, still I am getting SMS verification, I just want Email verification...



Hi Riyas,

Check below links
let us know if it helps you and mark it best if it helps you

Bhanu Prakash
visit ForceLearn ( salesforce Latest Updates and development tips
Riyas MRiyas M
Hi Bhanu,

Thanks for the answer, but I already tried you suggested methods but still I am getting phone verification instead of email...

In this article author suggesting to  Select "Email-Based Identity Confirmation Option" checkbox but that not possible because I cannot edit "System Administrator " profile because of standard profile I think... so I cloned this profile as a new one and Selected "Email-Based Identity Confirmation Option" checkbox.  and assigned my user to this newly created profile... still I am getting phone verification... :( 

Anyway thanks for your time!!!

Admin User 8101Admin User 8101
Hi Guys,

Any update on this? I'm not even able to find this option anywhere. We got one external user that do not have a business phone, and we would like to set for him only email as the second form of authentication - but I am not able to find a way.

Any help appreciated.
Kindest regards,

Pawel J.
Anybody have a solution for this? I am trying to implement email authentication and created a permission set and enabled Email-Based Identity Verification Option and assign it to the user. 
Followed as per the instructions on the help page-
but no luck.  Still it is going to Salesforce Authenticator app and not sure what I am missing.  No phone # is available on the user record as well.

Setup | Security Controls | Session Settings, select Enable the SMS method of identity verification
Setup | Manage Users | Profiles (Custom Profiles) | System Permission, select Email-Based Identity Verification Option
Setup | Manage Users | Permission Sets | New permission sets with Email-Based Identity Verification Option enabled and assigned to the user.
Please let me know.  Thanks in advance for your help. 
Kameshwari GantiKameshwari Ganti
How can I receive an email with the 5 digit verification code when I’m logging in from a network SF doesn’t recognize. I have enabled the  "Email-Based Identity Verification Option" permission and removed the mobile no from the user profile, but still the user is not getting the 5 digit code to his outlook.