function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Tj AnandTj Anand 

Not able to see "Knowledge Article Types" under setup after activating Knowledge in Service Cloud.

I am following trailhead
However after enabling the knowledge in service cloud, I am not able to see the article types in setup. 

Any suggestions?klo,
NagendraNagendra (Salesforce Developers) 
Hi Anand,

Do you have a knowledge user permission on your user record?

Do you have manage knowledge permission?

Did you make sure the user's profile has Read/Create permission for all Article Types? Please remember that each Article Type is an object on its own so you need to set permissions for each Article Type a.k.a. object for the user profile.

Have you enabled Lightning Knowledge in your Salesforce Org? If yes then you cannot create Article Type in Knowledge you can create record Type

Setup -> Customize -> Knowledge -> Knowledge Object Setup -> Scroll down to Record Types Section and Created New.

Hope this helps.

Kindly mark this as solved if the information is helpful.

Tj AnandTj Anand
Thanks Nagendra, 

I dont have any record types created. I have created a new on with label as "New" and assigned it to all the profiles. Still the Article Types doesnt show up in setup. 

One following link :
I get error: You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors. 

Natalya MurphyNatalya Murphy
Thanks for posting this @Nagendra.  For some reason, when I typed Knowledge in Quick Find, nothing came up.  But by following the Setup -> Customize -> Knowledge path you listed, I finally found it.