function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Andrew Schneider 10Andrew Schneider 10 

Trailhead - Analyze Your Data Over Time - Einstein Analytics

I am having an issue with this challenge as well, I am doing everything it asks and don't see what I'm doing wrong.  The instructions are:
Dataset: DTC Opportunity
Add Group: Close Date (Year-Month)
Add Group: Forecast Category
Change Measure: Count of Rows to Sum of #
Filter by: Closed Equals False
Chart Type: Timeline
Lens Name: Sales Pipeline Overview

I double checked I am saving to My Exploration and copy and pasted the title exactly from the instructions.  HELP!

User-added image
SandhyaSandhya (Salesforce Developers) 

Did you sign up with new wave enabled org as older org wont work for this and creating new org worked for me.Sign up from below link
Also refer below link.
Please mark it as solved if my reply was helpful. It will make it available for other as the proper solution.
Best Regards

Jeanette StanfordJeanette Stanford

Did you ever get this to work? I am also having this issue. My query is correct, yet I cannot pass the challenge. This is the second time this is happening with this trail and it is quite frustrating as it is wasting my time. The recommnedation from Sandhya of downloading a new org did not work. 

Any recommendations?

Thank you,
Jose Manuel Gonzalez AriasJose Manuel Gonzalez Arias
Hi Andrew, Sandhya, Jeanette,

I was fighting with the same problem. Simply I deleted the file, started again doing it step by step and worked.

Hope it works for you.

Andrew Schneider 10Andrew Schneider 10
I tried the links referenced above, signed into the new Dev playground, and I still get the same query error message.
Garrett Hunt 9Garrett Hunt 9
Agree with Jose Manuel.  I deleted the lens, started over, did the steps in the exact order specified and it worked.  I am using a new org as of a few days ago.  FWIW, I also hit the "Launch" button before starting just to be absolutely certain that there was no confusion about which dev org to check.  It failed for me several times before this.  Very touchy.
Same for me, deleted the Sales Pipeline Overview lenseand recreated in the exact order:
  1. Created new Lense by clicking on the DTC Opportunity Dataset
  2. Changed the chart type to Timeline
  3. Added the time Axis
  4. Added the X Axis
  5. Added the lines
  6. Added the filter
  7. Saved