function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Luke Osmundson 2Luke Osmundson 2 

Communities Change Set issue.

I am attempting to deply a change set containing a community from one Sandbox to another. Per the document listed below, the community was created on the second sandbox, and given the same name and template type. When the change set was pushed, the following error was received.

"Sorry, this URL is already taken."

In order to resolve this, the URL for the community on the second sandbox was changed. The error persisted. The URL extension on the original sandbox community was changed as well, to no avail. 

Does anyone know what URL is being referred to?

Nancy Everest --Nancy Everest --
I am getting this same error. Has anyone solved this? I am beginning to wonder if you really can use change sets to move a community. You have to do so much manual prep and changing of settings before building the change set that it doesn't seem like it really works.
Luke Osmundson 2Luke Osmundson 2
We just do our changes manually at this point, using change sets only for moving components such as VisualForce pages, Apex Classes, static resources, etc. Change Sets seem to cause all sorts of strangeness with communities.
Nancy Everest --Nancy Everest --
Thanks for the confirmation of my suspicions. Sounds like a plan, though it would be nice to be able to move it all over from our sandbox to production.