+ Start a Discussion
Mathias Denzin 4Mathias Denzin 4 

Set Up the Exchange Rate


it's about the task "Set Up the Exchange Rate" in trail "Learn Admin Essentials in Lightning Experience"
My Org was set to EUR as currency. So I added USD and change my Org to USD. But I cant finish the challenge.

User-added image
And the company "United Oil & Gas, UK" was not available in my Org. So I took another one. Is that a mandatory step?
NagendraNagendra (Salesforce Developers) 
Hi Denzin,

Sorry for this issue you are encountering.

The problem is you don't have an existing opportunity called united oil and gas. That is the name of the account on which you are creating the new opportunity with a new currency.

You can find the account name united oil and gas by clicking on the accounts tab and selecting the view as all accounts.

Then get into the opportunity tab click on new opportunity then enter the details as shown in trailhead and specify the currency and save the opportunity record. You will be successfully able to pass the challenge.

Please let us know if you have any issue.

Happy to help further.

Kindly mark this as solved if the reply was helpful.

Narender Singh(Nads)Narender Singh(Nads)
Hi Mathias,
You need to first set your org's currency to USD and then follow the module steps to set mutiple currencies.
Next, refer the screenshot to create the opportunity on United Oil & Gas, UK account.
User-added image

Let me know if it helps
Jean-Luc LetermeJean-Luc Leterme
Hi guys,
Got the same issue, stuck on that unit.  Didn't work with my previous orgs.  Tried brand new playground, set corp currency to USD, changed my profile to make sure USD too (instead of my local Australia AUD), proceeded with challenge steps from scratch and still get the same error message : "Challenge Not yet complete... here's what's wrong: 
We couldn’t find Currency Type and ConversionRate with the correct information. Ensure that you have selected the correct currency type and entered the conversion rate."
Tried to set the conversion rate back to 1.5 instead of the 1.0 that ends the challenge - same result.
Quite frustrating at this stage...
Thanks for any help you can provide.
Josip KrajnovićJosip Krajnović
I have the same issue as my corporate currency was set to EUR, also tryed changing it to USD, still stuck.
Josip KrajnovićJosip Krajnović
Enabling the Advanced Currency Management in Step 2 worked for me and I got Step 1 verified...
Josip KrajnovićJosip Krajnović
Hint for the last Step, don't name the support group "All Support Group", name it "All Support"
Johan KarlsteenJohan Karlsteen
I have finished all steps except Step #2, same problem as others:
"We couldn’t find Currency Type and ConversionRate with the correct information. Ensure that you have selected the right currency type and entered the conversion rate."
Johan KarlsteenJohan Karlsteen
I got it to work now, this is how I did it:
  1. Create a new Trailhead Playground
  2. Set Corporate Currency to USD under Company Information
  3. I also set Language to English, Locale to English and Timezone to Los Angeles
  4. Start with Step #1 and now you should be able to pass Step #2
I'm guessing that the problem is that the Corporate Currency on a new Trailhead org is dependent on your setting so if you get a non USD-org from the start you might end up with problems.
Katia PadfieldKatia Padfield
I can confirm that Johan Karisteen's solution worked for me too.
In addition to his 4 points above, I also verified Step #2 first and then Step #1 (without having to revert to previous settings).

Thanks for your help Johan!
Lisa StephensonLisa Stephenson
After I got the exchange rate error, I enabled the Advanced Currency Management as suggested by Josip Krajnović and it passed without any issue. 
Connie Hazendonk 1Connie Hazendonk 1
done exactly what was outlined, created a new org, set corporate currency to USD, changed locate just in case.
Went through the steps and still get the error. It's soo frustrating as this is such a simple thing to do, pretty much fool proof. Yet is still doesn't work for some reason. Don't want to give up but getting close to it!
Josip KrajnovićJosip Krajnović
Hi Connie,

Have you tryed to enable the Advanced Currency Management? if not enable it and try to verify the challenge again.

Let me know if it helps
Connie Hazendonk 1Connie Hazendonk 1
Thanks Josip, that worked. Had to go to classic mode to find it :-) Now I can hopefully complete the rest of the module!
Josip KrajnovićJosip Krajnović
There are a few smaller bugs/typos and one more on which I was stuck, here is the link https://developer.salesforce.com/forums/ForumsMain?id=9060G0000005dSZQAY
Josip KrajnovićJosip Krajnović
Hi all,

I hope I haven't created to much confusion, the link in my previous post is for the "Customize a Salesforce Object" project in the Learn Admin Essentials in Lightning Experience trail.

And here is one more for the last project in this trail "Improve Data Quality for a Cleaning Supply App" on which I was stuck.

Hope this helps save some time and frustration.

Best regards,
Maria C.Maria C.
Huh. I was stuck on Step 1. The Opportunity value refused to change even when the exchange rate was correct.
For me disabling Advanced Currency Management is what worked (which is funny because few people in this thread said that enabling it solved their issue). 
Maria C.Maria C.
Also, make sure the account is United Oil & Gas, UK and not United Oil & Gas Corp.
Thanks, I had the wrong United Oil & Gas - would have taken me ages to spot. Youre a life saver
Paulo Rafael MoreiraPaulo Rafael Moreira
I from Brazil and I could be able to pass throught in this exercise, follow Johan Karlsteen tip's

"Create a new Trailhead Playground
Set Corporate Currency to USD under Company Information
I also set Language to English, Locale to English and Timezone to Los Angeles"

and also changed the name of the company. Instead "United Oil & Gas, Reino Unido" I put "United Oil & Gas, UK"
If i dont changed, doesn't work.

After that i could pass  throught. 
Cícero SchoepsCícero Schoeps
Editing the account name to "United Oil & Gas, UK" as advised by Maria C.worked for me, too. Thanks!!
Carlos Garcia 68Carlos Garcia 68
HERE WHAT WORKED FOR ME (Pay attention to the 3rd point here):
1-Important: When you finish step 1, close your Trailhead Playground, go to step 2 and Lunch it again to complete the changes requested on that step)
2-(I changed to: Default LocaleEnglish (United States) / Default LanguageEnglish/ Default Time Zone(GMT-05:00) Central Daylight Time (America/North_Dakota/Center)

3-I think this error has to do with the format provided on the instructions.
Instead of putting:
-Conversion Rate 1.5 put 1,500000 (Decimal places: 2 are ok)
-On Edit Rates Euro to instead of putting 1.00 put 1,000000
or instead of putting 1.13  put 1,130000
-Changing the format worked for me.