+ Start a Discussion
Nitika GuptaNitika Gupta 

Module: Share, Schedule, and Subscribe to Reports and Dashboards - Issue with completing challenge

When I hover over a dashboard component, it does not display the Hover menu icon for dashboard components menu. So I'm unable to post a snapshot to the dashboard feed.
I tried to switch from SF Classic to Lightning to see if that would make it work, it allows me to take a snapshot but automatically posts to a group - no option to select the dashboard feed.
RakeshRakesh (Salesforce Developers) 
Hi Nitika,

Please go through the below instructions and try to post a snapshot. If you still unable to post the snapshot, Please let me know. Happy to help you further!
  • If you don’t see the option to follow a report or dashboard, you may need to enable Feed Tracking. From Setup, enter Feed Tracking in the Quick Find box and click Feed Tracking and then select Reports. Select Enable Feed Tracking, and optionally select fields to track, if you’d like to see updates in your feed when those fields change.
  • Repeat the same steps to enable Feed Tracking for dashboards. From Setup, enter Feed Tracking in the Quick Find box and click Feed Tracking and then select Dashboard. Select Enable Feed Tracking, and select any fields you want to track.
  • In order to post a snapshot, you must have the appropriate setting enabled in Setup. From Setup, enter Reports and Dashboard Settings in the Quick Find box and click Reports and Dashboard Settings. Select the Enable Dashboard Component Snapshots checkbox, and click Save.
Hope this helps you!
Please mark it as solved, If this reply was helpful.

Thanks,
Rakesh Thota
Team Marketing 11Team Marketing 11
I've had the same problem but have activated Feed Tracking as well as Component Snapshots.  Instead of a hover option it shows a Download or Share Component icon.  Could this be part of the new release?
Download & Share icons instead of hover with Post to Chatter etc
Howard LubingerHoward Lubinger
Yeah.  I just had to expand the component and click the share component icon.