+ Start a Discussion
Anna DiazAnna Diaz 

Trailhead module error: Build Recruiting App-create custom object for reviews

Hello. I'm trying to start on the Build A Data Model for a Recruiting App Project. https://trailhead.salesforce.com/projects/build-a-data-model-for-a-recruiting-app/steps/create-a-custom-object-for-reviews It asks that I install an unmanaged package but when i click on the link provided it says the app cannot be installed because the package is not found. 
"The requested package doesn't yet exist or has been deleted. If this is a recently created package version, please try again in a few minutes or contact the package publisher."
I need to understand roll-up fields (starting from the basics) so i need to complete this or is there another, newer module that will explain it better?
Velma McConnellVelma McConnell
I am having the same issue. 
Vijaya SridharanVijaya Sridharan
I am seeing the same issue.
Ryan ShoutRyan Shout
I am having the same issue.
Matthew StaffordMatthew Stafford
I too am havong this problem and have no idea where to begin to remedy this. Any help would be greatly appreciated
Ryan ShoutRyan Shout
Using the chrome browser:

The solution to the Package Not Found issue for me was to create a new Trailhead Playground.
 Once the brand new Trailhead Playground was created, I followed the process to get my username and reset the password. 
Then I launched the new plaground in a fresh tab.
Then clicked the link in the module to download the unmanaged package and was directed to the installation options page.

Hope this helps!
Matthew StaffordMatthew Stafford
Hi Ryan, thanks for this. Unfortunately that didnt work. I have tried 3 different browsers, cleared cache, incognito mode, new playground, different computer but all result in the same problem. :(
Matthew StaffordMatthew Stafford
Interestingly my colleague managed to get it working, but not for my profile, and that was on his own laptop, which I also tried to no avail
Ryan ShoutRyan Shout
Very strange! I did the multiple browser, incognito modes, cache clearing as well. Time consuming and frustrating. I am glad your colleague got it worked out. Hopefully the issue is limited to this TH Module and does not pop up the next time you try to install an unmanaged package in another org.
sekar krishnan 15sekar krishnan 15
I am trying to do a project "Build a Data Model for a Recruiting App".It has reference to Position__c object but it doesn't have any details in related to Position__c object creation mentioned anywhere.
Stuart PriceStuart Price
Sekar - I have the same issue with "Build a Data Model for a Recruiting App" and I cannot find any other modules that provide the details required for the Position custom object. Can anyone help?
Mars Rover 566Mars Rover 566
Try a developer org (not a playground org).
Anna DiazAnna Diaz
i am on a developer org
Nancy Brown 35Nancy Brown 35
The Position object would have been included in the App that we can no longer download. I created a Recruiting app with a Position object. I created  fields referenced in the test mentioned in the 3rd challenge named Create a Custom Junction Object for Job Postings for this module. Now I am stuck on the 4th challenge cause I can't get the lookup filter to work. The last challenge calls for a master-detail relationship field to the Job Applicaton object and a look-up relationship to the Interviewer object. I might try and guess at creating those objects so I can finish this challenge.
Peale ObiedoPeale Obiedo

Hi All, I'm still encountering the issue of the original post, where the unmanaged package cannot be install, see error below:

This app can't be installed.
There are problems that prevent this package from being installed.
The requested package doesn't yet exist or has been deleted. If this is a recently created package version, please try again in a few minutes or contact the package publisher.

This is the link provided in the Module: Create-a-custom-object-for-reviews

Please help. Thank you!

David NavaDavid Nava
I have this issue as well. There is no existing solution....
Rob PezzuloRob Pezzulo
Developer Docs has outlined how to build the custom object: https://developer.salesforce.com/docs/atlas.en-us.fundamentals.meta/fundamentals/adg_simple_app_define_custom_object.htm
You have to jump around a bit to see the final object, but it is all there: https://developer.salesforce.com/docs/atlas.en-us.fundamentals.meta/fundamentals/adg_simple_app_fields_look.htm
Even same issue for me as well, tried with newly created playground and developer org. but no luck. is there a way to escalate this issue to trailhead team?

Michael Sheehan 34Michael Sheehan 34
FYI, this doesn't address the inital question on the module failure in trailhead but you can create the recruiter app with the below link for step by step instructions, https://developer.salesforce.com/docs/atlas.en-us.fundamentals.meta/fundamentals/adg_preface.htm
Michael Sheehan 34Michael Sheehan 34
To answer the original question, when you click on the install link that looks like this: https://login.salesforce.com/?ec=302&startURL=%2Fpackaging%2FinstallPackage.apexp%3Fp0%3D04t0P000000N9rs

replace the domain with that of your playground instance, if you haven't created one yet scroll down to the bottom of this project and launch a playground instance. So my playground home url looks like: https://brave-raccoon-klv0y8-dev-ed.lightning.force.com/one/one.app#eyJjb21wb25lbnREZWYiOiJvbmU6YWxvaGFQYWdlIiwiYXR0cmlidXRlcyI6eyJhZGRyZXNzIjoiL2FwZXgvdGhfY29uX2FwcF9fVGhIb21lcGFnZSJ9LCJzdGF0ZSI6e319

If I replace my domain https://brave-raccoon-klv0y8-dev-ed.lightning.force.com and add ec=302&startURL=%2Fpackaging%2FinstallPackage.apexp%3Fp0%3D04t0P000000N9rs to create the url: 


it will install w/o an issue. Sorry if this is a bit verbose but it's for those who might not have used a playground yet in trailhead.
Peale ObiedoPeale Obiedo
Thanks @Michael Sheehan, I tried the link you provided for the Recruiting App package and I have successfuly installed it on my playground.
We can't save this record because the “Create Interviewer Record” process failed. Give your Salesforce admin these details. This error occurred when the flow tried to create records: FIELD_INTEGRITY_EXCEPTION: Employee: id value of incorrect type: a0G0o00002fP74UEAS. You can look up ExceptionCode values in the SOAP API Developer Guide. Error ID: 612301618-6868 (1707183304)
Julie YlshJulie Ylsh

Hi guys, 

If it's any help, solved it by replacing the URL in my domain by : https://my-domain.lightning.force.com/packagingSetupUI/ipLanding.app?apvId=04tB00000009oZ3JBI with the good package URL (you can have it when you go on the page that doesn't work)

Amitesh Patara 8Amitesh Patara 8
Please Help me I can't find "Job posting site" in Add more items in Recruiting app as per the challenge https://trailhead.salesforce.com/content/learn/projects/build-a-data-model-for-a-recruiting-app/junction-object-job-postings
Amitesh Patara 8Amitesh Patara 8
I found it but I can't add site URL andname as staed in challenge at last