function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Jacques CONANJacques CONAN 

The 'Rating' permission set does not have the appropriate field-level security for the Account Rating field.

I am trying to complete the challenge for Admin Intermediate > Data Security  > Control Access to Fields.
I cannot give the Rating permission set access to account Rating field: Read Access, Edit Access.
I get the error message "The 'Rating' permission set does not have the appropriate field-level security for the Account Rating field."
I don't know where to set this up. Here is the only thing I can see from the Permission Set screen:
User-added image
Thanks in advance for your help.
SandhyaSandhya (Salesforce Developers) 

Go to Accounts - > Fields -(Pick rating field) - > click button "Set field level security" and uncheck everything in visible and read only check boxes  expect for basic account user - > visible and readonly should be checked only for basic account user basically.

Permission Set -> object setting -> Account-> field permission section -> check read & edit then save.

Please mark it as solved if my reply was helpful, it will make it available
for others as a proper solution.

Best Regards,
Jacques CONANJacques CONAN
Hello Sandhya,
I cannot got to Accounts, I only get a Users option in Setup. Also from Permission Sets and cannot get to Object Setting.
This sounds strange...
This isn't solved for me unfortunately.
SandhyaSandhya (Salesforce Developers) 

My apologies, I have given you steps in salesforce classic.In Lightning you can click SETUp from gear Icon--object manager-- Accounts.And also the last step is Permission Sets-- click on Permission Set you created -- object setting -> Account-> field permission section -> check read & edit then save.

Refer below link for help.
Best Regards,
Jacques CONANJacques CONAN
Hi Sandhya,
I am now getting the error:
"The 'Sales' profile does not have the appropriate field-level security for the account Rating field."
The challenge text says that on the Sales profile, one must set "Field Permissions: Rating on the Account object (remove Read Access and Edit Access)".
I don't know how to do this.
Thanks again.
Jacques CONANJacques CONAN
Hi Sandhya,
I managed to remove Read and Edit Access on Rating for the Sales profiles.
I don't have the previous error but I am still getting the error "The 'Rating' permission set does not have the appropriate field-level security for the Account Rating field."
I am still stuck on this one.
Jacques CONANJacques CONAN
Here is the setting for the Rating Account field in the Sales Permission Set:
User-added image
I just don't get it.
C P 13C P 13

Hi Jacques,

When I did mine just now, on that list of permissions in your last post, I checked read/edit on all five items that contained "Account"... Account Name, Account Owner, etc. Maybe try that?

User-added image

Fabrizio Fitzgerald FarinaFabrizio Fitzgerald Farina
Hi Jacques, 

I had the same problem. I solved it as I spotted that in the Permission Sets I selected "Sales User" from the license drop-down list instead of "Salesforce".

I noticed from your first screenshot that you did the same. Hope this helps!

Michael KraanMichael Kraan

Hello Fabio,

Thanks! that was exactly my problem. 

The reason for this was that i cloned an excisting permission set. (as they teach you in the turtoriol) instead of making a new one. Took me 1,5 hours to figure out 

Hope this helps everybody else.




少阳 于少阳 于
I just got the same problem,and solved it successfully,thx Sandhya  
salman ahmed 35salman ahmed 35
The 'Rating' permission set does not have the appropriate field-level security for the Account Rating field.
Kenny Allen-Kenny Allen-
I was stuck on this as well and after reading the thread, I saw Michael Kraan;s responce and it hit me, Make a NEW Permission Set. LOL
Madhura ParalikarMadhura Paralikar
In the field permissions give read and edit access to the rating field (The permission set that you just created), that worked for me.
While Creating the new persmission set as label as Picklist and when you dont find Rating in Account object then give the access to Prospect Rating ..It help for me in Passing the Challenge
This might help
Thanks Regards,
Mohammed Faiyaz Uddin  
Federica ColomboFederica Colombo
Hi everybody, 
i'm stuck with this since 2 hours...i tried all the suggested way but nothin to do...
Suraparaju MohanSuraparaju Mohan
its not showing saleforce in license ..please help me out

good morning 
 its not showing saleforce in license ....please help me out 
Reiya HoriiReiya Horii

This video tells everything.

Davis ColeDavis Cole
This is some bull. I have been working on this for over 2 hours and your video tutorial above from 2019 doesn't even match what I have. There is no edit button to make all of those fancy edits.
User-added image

You can click on Object settings then accounts, then edit to see the next screen shot where no access is not allowed. Some boxes are still grayed out.

User-added image

Has anyone new, come across this issue? I'm stuck!
Vitalii BoiandinVitalii Boiandin
Hi)  today i complete this task) Maybe my message can help somebody)
When you create  Rating, you should go to Object settings- Account and select Read and Edit in the field Rating.
Thats all))
Raphael BoucherRaphael Boucher
Hi, After tying for several hours and still the same message
"In the Sales profile, we can't find the correct permissions for the Rating field on the Account object."
I add a new Playground and it works!!!
Don't forget to switch to your new playground when you launch the challenge switch to another playground
Hope it will help ;)
Ayush Verma 7Ayush Verma 7
i just changed the name of the field "Prospect Rating" to "Rating" in Account Object, Because during one of the assignment we changed it to Prospect Rating.
It  Worked for me...
Quick Find -> Rename Tabs and Labels -> click Edit next to Accounts -> Next - > (change Prospect Rating to Rating in Rating Column) Rating -> Save
again go to permission set and do the neccessary changes.
Alex Ho 16Alex Ho 16
For the new Lighting Salesforce, here solution:
Open Sales profile, do not click Edit, just scroll down to Field-Level Security and Standard Field-Level Security, go to Account [view]. In there, you can remove Read and Edit Access for Rating
Arivalagan V 10Arivalagan V 10
No issue just do the same for Prospect rating field, both are same only & its field name is Rating.
Yevgen GakYevgen Gak
Ayush Verma 7 is right, that will help, but the easiest solution will be to switch Playground ) In one of the previous challenges there was a task to rename "Rating" field to "Prospect Rating" in the Account Object, so if you did it, just rename it back or as I said, switch the Playground.
Nancy Freeman- RocheNancy Freeman- Roche
II can't resolve this error.  When I do the challenge, I get this message:  In the Sales profile, we can't find the correct permissions for the Rating field on the Account object.  I updated the standard object permissions for the Sales profile, but that didn't work either. I don't know where to go from here. Thanks.
Imola CerulliImola Cerulli
Thanks for the tips! This was driving me nuts as well, the easiest solution was indeed to start a New Playground! :) Until now I alway worked with the previous one, the upcoming exercises never "clashed" with the previous work we already did.
Matt Hyland 24Matt Hyland 24
I found the problem was when you pick the license for making the permission set, the dropdown is not in alphabetical order.  After i realized that it worked like a charm.  Only took me 2 hours.
winifred  Nneka Udoyewinifred Nneka Udoye
Hello I am still having the same issues  . how do  i   sort it out 

 Error message  :    
Challenge not yet complete in Creative me Playground
In the Sales profile, we can't find the correct permissions for the Rating field on the Account object.
Sivaranjani JayarajkumarSivaranjani Jayarajkumar
Create a new permission set:
Label: Rating
API Name: Rating
User License: Salesforce

While doing this step : User  License field is not in alphabetical order to find salesforce value in dropdown and create the permission set. it works fine... Then it would have the object settings option.
Ryan Wilson 61Ryan Wilson 61

Reiya Horii from March 18, 2021 has the best answer ^^^